Opened 16 years ago

Closed 16 years ago

Last modified 12 months ago

#910 closed defect (wontfix)

BEOS: Cursor problem

Reported by: SF/hansjak Owned by: SF/khalek
Priority: normal Component: Port: BeOS
Keywords: Cc:
Game:

Description

steps to reproduce behaviour:
- start scummVM 0.4.1 for BeOS
- select a game
- press "start"
--> crash

in order to play the game i have to open the
option-dialog first, click ok and then play. if i do
that, everything works fine.

-----------------------------------------------------------

after starting scummVM 0.4.1 for BeOS, the cursor moves
to the lower right corner. to stop that, i have to
press all cursor-keys. after that, it stops.

maybe forgot to clear a key-status-table ? (just an
idea...)

Ticket imported from: #757380. Ticket imported from: bugs/910.

Change History (12)

comment:1 by Kirben, 16 years ago

Do these problems occur with recent ScummVM CVS version
too ?

comment:2 by Kirben, 16 years ago

Summary: BeOS ScummVM crash when starting & Cursor-ProblemBEOS: ScummVM crash when starting & Cursor-Problem

comment:3 by SF/hansjak, 16 years ago

i don't know... i'll check that right after my vacation.

comment:4 by SF/hansjak, 16 years ago

i'm not enough expirienced to install all neccesary
libraries and compile the whole thing... could anyone be so
kind and send me the newest daily build for beos ?

to adadadad@gmx.net

thank you very much

comment:5 by SF/hansjak, 16 years ago

i used the following version to test again:

http://www.bebits.com/app/3429

it's denoted as "version 0.5.0-Pre"

the crash at startup is resolved, but the cursor still keeps
going to the lower right corner...

comment:6 by Kirben, 16 years ago

Does the cursor issue only occur with Simon the Sorcerer 1 or
with other games under ScummVM too ?

This is a BeOS specific issue

comment:7 by Kirben, 16 years ago

Summary: BEOS: ScummVM crash when starting & Cursor-ProblemBEOS: Cursor problem

comment:8 by SF/hansjak, 16 years ago

it seems to be beos specific, indeed...

could an admin move my post?

comment:9 by Kirben, 16 years ago

Component: Engine: AGOS
Game: Simon the Sorcerer 1

comment:10 by SF/khalek, 16 years ago

I don't see how this can be a ScummVM problem, more likely
SDL. In any event the version mentioned is somewhat old.

If you have a joystick make sure it is properly callibrated
and that SDL for BeOS actually works with joysticks.

closing

comment:11 by SF/khalek, 16 years ago

Owner: set to SF/khalek
Resolution: wontfix
Status: newclosed

comment:12 by digitall, 12 months ago

Component: Port: BeOS
Note: See TracTickets for help on using tickets.