Opened 16 years ago

Closed 16 years ago

Last modified 13 years ago

#893 closed defect (fixed)

SIMON2: Hanging notes

Reported by: Kirben Owned by: SF/jamieson630
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 2

Description

Latest ScummVM cvs version.
English version of Simon the Sorcerer 2 for Windows
Compiled under mingw with GCC 3.2.3 and running under
Windows XP.

I'm getting hanging notes in Simon the Sorcerer 2
sometimes. Save game is attached.

Ticket imported from: #755176. Ticket imported from: bugs/893.

Attachments (1)

simon2.058 (2.9 KB ) - added by Kirben 16 years ago.
Go up stairs and you should note a hanging note as music changes.

Download all attachments as: .zip

Change History (8)

by Kirben, 16 years ago

Attachment: simon2.058 added

Go up stairs and you should note a hanging note as music changes.

comment:1 by Kirben, 16 years ago

The following cvs change seems to be the cause:
http://cvs.sourceforge.net/cgi-
bin/viewcvs.cgi/scummvm/scummvm/sound/midiparser.h.diff?
r1=1.15&r2=1.16

comment:2 by SF/jamieson630, 16 years ago

Should be fixed in latest CVS. Will wait for confirmation before
closing. Sorry about the regression.

comment:3 by SF/jamieson630, 16 years ago

Resolution: fixed

comment:4 by Kirben, 16 years ago

Yes the problem is fixed, so closing.

comment:5 by Kirben, 16 years ago

Status: newclosed

comment:6 by fingolfin, 14 years ago

Component: Engine: AGOSEngine: SCUMM
Game: Simon the Sorcerer 2Putt-Putt Travels Through Time

comment:7 by Kirben, 13 years ago

Component: Engine: SCUMMEngine: AGOS
Game: Putt-Putt Travels Through TimeSimon the Sorcerer 2
Note: See TracTickets for help on using tickets.