Opened 16 years ago

Closed 16 years ago

#891 closed defect (fixed)

LOOM: gfx glitch when leaving Lady Cygna's gravestone

Reported by: SF/lord_nightmare Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

When leaving Lady Cygna's gravestone to return to the
clicking-and-walking part of the game, the gravestone
is supposed to do a blocky dissolve-fade transition,
with no color changes. Instead, the color of ALL the
text on Lady Cygna's gravestone changes from dark blue
to dark magenta as soon as the transition starts.

Attached savestate is standing in front of gravestone.

Using latest CVS version, as always.

Lord Nightmare

Ticket imported from: #755124. Ticket imported from: bugs/891.

Attachments (1)

loom.s02 (57.6 KB) - added by SF/lord_nightmare 16 years ago.
loomega savestate: standing in front of gravestone

Download all attachments as: .zip

Change History (4)

Changed 16 years ago by SF/lord_nightmare

Attachment: loom.s02 added

loomega savestate: standing in front of gravestone

comment:1 Changed 16 years ago by eriktorbjorn

Probably a consequence of the palette being remapped, and
then changed back to its original state when a transition
effect starts.

I can confirm that this doesn't happen when running Loom in
DOSbox in this particular case. There is at least one case
where it does happen in DOSbox as well, so I don't know yet
why this case is different.

comment:2 Changed 16 years ago by Kirben

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:3 Changed 16 years ago by Kirben

Fixed in ScummVM cvs.

Note: See TracTickets for help on using tickets.