Opened 17 years ago

Closed 17 years ago

Last modified 2 years ago

#867 closed defect (fixed)

ALL: ScummVM crashes on exit

Reported by: eriktorbjorn Owned by: SF/jamieson630
Priority: normal Component: Port: Win32
Keywords: Cc:
Game:

Description

With the latest CVS snapshot, ScummVM usually (always?) crashes on exit, when using a MIDI sound driver such as -ealsa or -ewindows.

I guess the recent addition of clear_sound_proc() only fixed the AdLib case.

Ticket imported from: #751781. Ticket imported from: bugs/867.

Change History (7)

comment:1 by eriktorbjorn, 17 years ago

I'm assigning this to Jamieson630, since I believe he may already have fixed it. I haven't had the chance to verify it yet though.

comment:2 by eriktorbjorn, 17 years ago

Owner: set to SF/jamieson630

comment:3 by SF/jamieson630, 17 years ago

Well, I did just fix the MPU401 (native drivers) crash-on-exit about an hour before this was assigned to me. Tell me if the fix works for you too. (Why don't I see you in IRC yet, eriktorbjorn?) ;)

comment:4 by eriktorbjorn, 17 years ago

The fix works for me -- I just had to apply it to the ALSA driver first. ;-)

comment:5 by eriktorbjorn, 17 years ago

Resolution: fixed
Status: newclosed

comment:6 by SF/jamieson630, 17 years ago

Sorry about that. I don't know how I missed that, since I grep'd the entire backends/midi directory. I also added the fix to the YPA1 driver -- I think that completes the suite.

comment:7 by digitall, 2 years ago

Component: --Unset--Port: Win32
Note: See TracTickets for help on using tickets.