Opened 16 years ago

Closed 15 years ago

#866 closed defect (fixed)

FT: ScummVM doesn't skip opening sequences correctly

Reported by: Kirben Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Full Throttle

Description

Latest ScummVM cvs version.
English version of Full Throttle
Compiled under mingw with GCC 3.2.3 and running under
Windows XP.

ScummVM doesn't skip the opening sequences of Full
Throttle correctly, it takes way too many skips to get to
the game itself. In the original game the first skip would
jump straight to outside the bar (The scene shown after
two skips under ScummVM) and the second skip would
jump straight to the game itself.

Ticket imported from: #751670. Ticket imported from: bugs/866.

Change History (4)

comment:1 Changed 16 years ago by Kirben

Also ScummVM doesn't allow certain points of the opening
sequence to be skipped. Just try skipping the complete
opening sequence of Full Throttle under ScummVM to see
what I mean.

comment:2 Changed 16 years ago by SF/yarrt

This bug is still present in latest CVS
ScummVM 0.5.0pre-cvs (Jul 22 2003 11:48:08)
ScummVM 0.5.0pre-cvs (Jul 26 2003 03:28:10)

OS: Windows 2000
Language: English

comment:3 Changed 15 years ago by fingolfin

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:4 Changed 15 years ago by fingolfin

Fixed thanks to MadMoose who tracked down the cause of this
(briefly, SMUSH runs from inside the script engine, and it calls
abortCutscene. But abortCutscene was never meant to be called
from inside the script engine, only from "outside" it, so this
caused problems).

Note: See TracTickets for help on using tickets.