Opened 16 years ago

Closed 16 years ago

Last modified 5 months ago

#864 closed defect (fixed)

MANIAC/ZAK: Verbs shown during keypads

Reported by: Kirben Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Maniac Mansion

Description

Latest ScummVM cvs version.
English versions of Maniac Mansion (Enchanced) and Zak
McKracken (Enchanced)
Compiled under mingw with GCC 3.2.3 and running under
Windows XP.

The verb commands section should not be shown during
the copy protection failure sequences. When the house
blows up in Manic Mansion and Zak is through in Jail in
Zak McKracken. This causes the verb commands section
to shown up when game is restarted too.
A screenshot from copy protection failure sequence in
original Zak McKracken and save games are attached.

Ticket imported from: #751664. Ticket imported from: bugs/864.

Attachments (3)

jail.jpg (43.6 KB) - added by Kirben 16 years ago.
zak.s06 (50.2 KB) - added by Kirben 16 years ago.
Use reservations terminal, choose London England, fail copy protection and watch sequence
maniac.s09 (56.0 KB) - added by Kirben 16 years ago.
Open door, fail copy protection and wait a few minutes

Download all attachments as: .zip

Change History (14)

Changed 16 years ago by Kirben

Attachment: jail.jpg added

Changed 16 years ago by Kirben

Attachment: zak.s06 added

Use reservations terminal, choose London England, fail copy protection and watch sequence

Changed 16 years ago by Kirben

Attachment: maniac.s09 added

Open door, fail copy protection and wait a few minutes

comment:1 Changed 16 years ago by SF/segra

Verbs should also not be shown during cutscene's

comment:2 Changed 16 years ago by fingolfin

Owner: set to fingolfin
Resolution: duplicate
Status: newclosed

comment:3 Changed 16 years ago by fingolfin

Duplicate of bug #753837

comment:4 Changed 16 years ago by Kirben

Actually, not really a duplicate bug. This problem is caused by
the verbs command sections been shown during cutscenes
and not be the restart function.

comment:5 Changed 16 years ago by Kirben

Owner: fingolfin deleted
Status: closednew
Summary: MANIAC/ZAK: Restart problemMANIAC/ZAK: Verbs shown during cutscenes

comment:6 Changed 16 years ago by Kirben

Verbs are no longer shown during cutscenes now but they still
show in a few other places. The verbs are shown when first
using the reservations termintal in the Airport and during copy
protection screens that follows, this doesn't occur in the
original game.

comment:7 Changed 16 years ago by Kirben

Summary: MANIAC/ZAK: Verbs shown during cutscenesMANIAC/ZAK: Verbs shown during keypads

comment:8 Changed 16 years ago by Kirben

The keypad on security door in maniac and keypad in airport
of zak are the best example of this problem now.
Also there are problems with text in verbs areas been cut off
in demo mode of v1 maniac which seems related. Will need to
remove work arounds in o2_cutscene() of script_v2.cpp and
in runInventoryScript() of script.cpp to see problems.

comment:9 Changed 16 years ago by Kirben

Owner: set to Kirben
Resolution: duplicatefixed
Status: newclosed

comment:10 Changed 16 years ago by Kirben

Last few issues with hiding verbs are fixed in ScummVM cvs.

comment:11 Changed 5 months ago by digitall

Component: Engine: SCUMM
Game: Maniac Mansion
Note: See TracTickets for help on using tickets.