Opened 13 years ago

Closed 13 years ago

Last modified 12 months ago

#8607 closed patch

KYRA: VQA player code cleanup/reduce

Reported by: cyxx Owned by: eriktorbjorn
Priority: normal Component: Engine: Kyra
Keywords: Cc:
Game:

Description

I was looking at the VQA player and noticed there was a duplicated function there. Basically, the decode80 routine is the same as Screen::decodeFrame4.

Added patch which removes the duplicated function (among other minor cleanups).

Ticket imported from: #1659302. Ticket imported from: patches/712.

Attachments (1)

vqa_player_cleanup.diff (7.0 KB ) - added by cyxx 13 years ago.
Re-use existing bitmap decoding code

Download all attachments as: .zip

Change History (7)

by cyxx, 13 years ago

Attachment: vqa_player_cleanup.diff added

Re-use existing bitmap decoding code

comment:1 by cyxx, 13 years ago

I haven't committed this directly, as I wasn't sure if it was done on purpose or not.

Which makes me also think that it could be a nice thing to rename Screen::decodeFrame4 to decodeFormat80 and Screen::decodeFrame3 to decodeFormat40 etc. to match other documentations.

comment:2 by lordhoto, 13 years ago

Any reason why Screen::decodeFrame4 returns uint32 and not just int (or uint)?
That's not that important though. :-)

Well we could rename them, I wouldn't mind if that would be done.

comment:3 by cyxx, 13 years ago

> Any reason why Screen::decodeFrame4 returns uint32

No particular reason at all, uint would be fine too

comment:4 by eriktorbjorn, 13 years ago

Committed, since LordHoto doesn't have any objections.

comment:5 by eriktorbjorn, 13 years ago

Status: newclosed

comment:6 by digitall, 12 months ago

Component: Engine: Kyra
Note: See TracTickets for help on using tickets.