Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#856 closed defect (worksforme)

INDY3-256: crash in Venice church

Reported by: SF/zsetrek Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 3

Description

In Venice church, when I try to <take> the barrier, the game crashes:

(18:203:0xC96C): (CDHD) Not found in 0... illegal block len -1977588372!
room: 183 [18]

scumm version: ScummVM 0.4.1 9 (I tryied CVS version too, ScummVM 0.4.2cvs, 8 jun 2003)
language: italian
version: floppy (not sure)
platform and compiler:
Linux pessimismo 2.4.20-ck6 #3 Tue Jun 3 13:34:07 CEST 2003 i686 unknown
gcc version 2.95.3 20010315 (release)

Ticket imported from: #750907. Ticket imported from: bugs/856.

Change History (4)

comment:1 by SF/zsetrek, 16 years ago

update: the problem is about the first barrier, infact if I <take> the second barrier, Indy tries to take the first barrier, and the game crashes.

comment:2 by SF/hibernatus, 16 years ago

Warning: the Italian version is not official. It has been made
by copying the scripts from Indy3 EGA. You should contact
the translators there: http://www.pollodigomma.net/iagtg/
At least the French version (which was made by replacing
text only, not scripts) works well in 0.4.1.
You should try with the english VGA version (which you should
have since the Italian patch was made for it :\ ).
Also you can try with the Italian EGA version.

comment:3 by fingolfin, 16 years ago

Works fine for me in german indy3, too. Must be as hibernatus
says: the italian version is hacked up and apparently the hacks
are not done quite correctly.

comment:4 by fingolfin, 16 years ago

Owner: set to fingolfin
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.