Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#855 closed defect (invalid)

No music with monkeyvga on PalmOS

Reported by: SF/chrilith Owned by: SF/jamieson630
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

Hi,

Don't know if this is a bug in the MIDI engine.
But i haven't anymore music on monkeyvga with lastest
CVS snapshot on PalmOS. It's was working on v0.4.1

Also in monkey island 2, there is no more sound on the
copy portection screen when items are switching (which
was also midi).

Thanks
Chris

Ticket imported from: #750871. Ticket imported from: bugs/855.

Change History (6)

comment:1 by fingolfin, 16 years ago

Definitely hear music here. The problem is probably there
because you don't have the adlib driver on PalmOS... assigning to
Jamieson as he made all the changes leading to this.

comment:2 by fingolfin, 16 years ago

Owner: set to SF/jamieson630

comment:3 by SF/jamieson630, 16 years ago

Sound effects will not play in MI2 under PalmOS because
those sounds are Adlib-only, and the ScummVM's Adlib driver
does not work on PalmOS.

As for monkeyvga, I don't have it, nor do I have a PalmOS, so
I can't test or verify this. Can any other PalmOS users provide
more information on how monkeyvga music is playing under
PalmOS?

Chrilith, try using the -eypa1 command line option when
running monkeyvga, and tell me if you can hear music then.

comment:4 by SF/chrilith, 16 years ago

I already used ypa1 driver but Monkeyvga music doesn't play.
MI2 sound on copy prot (and only this one) were midi and
played with previous version.

comment:5 by SF/jamieson630, 16 years ago

Okay, talks on IRC led to the following conclusions:

(1) MI2, FOA, DOTT, and S&M are all playing MUSIC fine
under PalmOS, but the MI2 sound effect tracks are not
playing. These are Adlib-only tracks, and Adlib is not
supported on PalmOS.

(2) monkeyvga uses the old 'AD' format music tracks, which
are also Adlib-only.

(3) Until recently, Adlib tracks WERE played through the
native music drivers, but the playback was inaccurate.
Recently all use of Adlib tracks with native music drivers
(including the Yamaha driver for PalmOS) was removed.

Until the Adlib emulator we employ uses little enough non-
heap memory (was that the problem?) to work with PalmOS,
any tracks that are Adlib-only will not play for PalmOS. Sorry
about the inconvenience.

comment:6 by SF/jamieson630, 16 years ago

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.