Opened 18 years ago

Closed 18 years ago

Last modified 21 months ago

#84 closed defect (fixed)

indy4: transition error leaving canal

Reported by: (none) Owned by: SF/ender
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

this occured after leaving the "archway" room (atlantis, canal; team mode, although sophia is currently in her cell) requiring the player to solve the puzzle in which you insert certain parts in the statue to move its arms (and pull open a door with an attached chain). i can provide a savegame right exiting the room.

$ scummvm atlantis Detected game 'Indiana Jones 4 and the Fate of Atlantis', version 5.5.0 1 1, 2 2, 4 4 4, 20 38 18 78 14792 WARNING: roomops:14 load-string(31,"iq-points") not implemented! WARNING: heapClear: not implemented! WARNING: unkHeapProc2: not implemented! Loading room 68 Adding object 933 from room 68 into inventory Adding object 937 from room 68 into inventory Adding object 938 from room 68 into inventory State loaded from 'atlantis.s08' Loading room 222 Error(94:206:0x15FE3): Invalid actor 205 in o5_getActorRoom! Press a key to quit.

$ rpm -q scummvm scummvm-0.0.3.20020128-1cm

(tried using a version manually compiled from scummvm-0.1.0b.zip as well)

Ticket imported from: #524080. Ticket imported from: bugs/84.

Change History (6)

comment:1 by SF/ender, 18 years ago

Owner: set to SF/ender
Priority: normallow

comment:2 by SF/ender, 18 years ago

Are you using the CD version or floppy?

Please attach a saved-game to help us work out where the problem is - it doesn't occur for me.

comment:3 by SF/ender, 18 years ago

Status: newclosed

comment:4 by SF/ender, 18 years ago

Fixed in CVS by Yazoo.

comment:5 by SF/ender, 18 years ago

Resolution: fixed

comment:6 by digitall, 21 months ago

Component: Engine: SCUMM
Game: Indiana Jones 4
Note: See TracTickets for help on using tickets.