Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#830 closed defect (invalid)

DIG: No scrolling in spider cave

Reported by: SF/zaurak Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

ScummVM 0.4.1 / WinXP & "The Dig" (German Mac CD-ROM)

Inside the spider cave the area doesn't scroll,
therefore it isn't possible to continue gameplay.
A savegame is attached. At Low's current position
the screen should scroll to the right, where an
exit to another room is located. However, the
screen doesn't scroll and the exit isn't reachable.

Regards,
Jan

Ticket imported from: #745818. Ticket imported from: bugs/830.

Attachments (1)

dig.zip (21.7 KB) - added by SF/zaurak 16 years ago.
The Dig savegame (ScummVM 0.4.1)

Download all attachments as: .zip

Change History (6)

Changed 16 years ago by SF/zaurak

Attachment: dig.zip added

The Dig savegame (ScummVM 0.4.1)

comment:1 Changed 16 years ago by eriktorbjorn

I haven't tried the savegame yet, but maybe it's related to
patch #733099 - the experimental DIG camera fix? It was
never applied to the branch that became 0.4.0 and 0.4.1,
only the trunk.

Basically, there are cases when The Dig "forgets" which
actor the camera is following, e.g. after opening and
closing the inventory window. That would probably cause the
kind of problem you describe.

comment:2 Changed 16 years ago by SF/zaurak

Although the concept behind patch #733099 is unknown to
me, I'm not sure whether this will solve the problem.
At that game position (see attached savegame) Low is the
one and only person that is actually present on screen.

The scrolling problem has occured only two times inside
the game so far: In the room from the attached savegame
and in the room before that room (where the screen also
doesn't scroll to the right but it should). Both times only
one actor (Low) is present on screen.

comment:3 Changed 16 years ago by fingolfin

The problem occurs in both 0.4.1 and latest CVS, erik. So much for that idea
:-/
At least this excludes my recent camera refecatoring and costume changes
from the list of culprits, too ;-)

comment:4 Changed 16 years ago by fingolfin

The problem is in the save game. Simply go back to the tram, travel to the
nexus: that'll reset the camera-follows-actor settings. After that you can go
back to the nest and everything works fine.

comment:5 Changed 16 years ago by fingolfin

Owner: set to fingolfin
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.