Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#826 closed defect (worksforme)

FT: Doesn't start anymore

Reported by: SF/chrilith Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Full Throttle

Description

Unable to start FT with lastest CVS snapshot (May
27, 2003, 7:38 pm v0.4.2cvs).

ERROR: (0:1:0x77a): o6_kernelSetFunctions :
default case 215 (param count 2)

Language : spanish
Platform : Win32

Works on v0.4.1 release

Chris

Ticket imported from: #744902. Ticket imported from: bugs/826.

Change History (6)

comment:1 by fingolfin, 16 years ago

Summary: Doesn't start anymoreFT: Doesn't start anymore

comment:2 by fingolfin, 16 years ago

At which point does it exactly crash? Does it also crash if you skip the intro
(by using ESC repeatedly) ?

I don't see that kernelSetFunction subop being called at all, hm.

comment:3 by SF/chrilith, 16 years ago

i use only *.lh? files. And the game doesn't start (go
directly on the debugger)

comment:4 by fingolfin, 16 years ago

.lh? files, hu? Do you mean the .la0 / .la1 files or what?

Anyway, subop 215 never was a legal opcode for the kernelSetFunctions. The
only scenarios I can think of where this would occur is if
a) your data files are damaged
b) there is a serious bug in ScummVM and your data files are somehow
different from all others, so that the problem doesn't occur for me but does
occur for you...

comment:5 by fingolfin, 16 years ago

Two other people can't reproduce it either. I think your game data files must
be bad.

comment:6 by fingolfin, 16 years ago

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.