Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#818 closed defect (worksforme)

INDY3: manhole crash

Reported by: SF/hibernatus Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 3

Description

ScummVM 0.4.2cvs
Built on May 27 2003.
under WinXP

Sometimes when Indy goes through the manhole in
Venice, i get a crash without parachute.
Here is a save game in the catacombs.

Ticket imported from: #744129. Ticket imported from: bugs/818.

Attachments (2)

indy3.s29 (41.8 KB) - added by SF/hibernatus 16 years ago.
catacombs entry. 0.4.2cvs 05/27
indy3.s30 (41.9 KB) - added by SF/hibernatus 16 years ago.
Directly under the manhole. 0.4.2cvs 05/27

Download all attachments as: .zip

Change History (15)

Changed 16 years ago by SF/hibernatus

Attachment: indy3.s29 added

catacombs entry. 0.4.2cvs 05/27

Changed 16 years ago by SF/hibernatus

Attachment: indy3.s30 added

Directly under the manhole. 0.4.2cvs 05/27

comment:1 Changed 16 years ago by SF/hibernatus

I've noticed that if scummvm doesn't crash once, it never
crashes, even if i load that save game again (indy3.s30).
But if i close scummvm launch it again, it can crash.

comment:2 Changed 16 years ago by fingolfin

Can't reproduce it.

comment:3 Changed 16 years ago by eriktorbjorn

It crashed once for me - with an SDL parachute message - but
unfortunately I've been unable to reproduce it while running
it in a debugger.

comment:4 Changed 16 years ago by eriktorbjorn

For some reason, I haven't been able to crash it at all in
the debugger, and only once when running it with the -d 9
option. That time the last things it printed were

Script 679, offset 0x7151: [13] o5_actorSet()
readvar(16384)
Script 679, offset 0x7157: [1A] o5_move()
Script 679, offset 0x715c: [80] o5_breakHere()
getResourceAddress(Buffer,9) == 17780748
getResourceAddress(Buffer,5) == 36332828
getResourceAddress(Buffer,9) == 17780748
getResourceAddress(Buffer,5) == 36332828
getResourceAddress(Buffer,9) == 17780748
getResourceAddress(Buffer,5) == 36332828
getResourceAddress(Buffer,9) == 17780748
getResourceAddress(Buffer,5) == 36332828
getResourceAddress(Buffer,9) == 17780748
getResourceAddress(Buffer,5) == 36332828
getResourceAddress(Costume,47) == 36242908
getResourceAddress(Matrix,2) == 17813324
getResourceAddress(Buffer,5) == 36332828
getResourceAddress(Buffer,9) == 17780748

But I don't know if this is useful or just a red herring. I
didn't get any parachute message this time because I had
deliberately turned them off, hoping to get a core dump.
Unfortunately MinGW isn't clever enough for that. Maybe I'll
have more luck when I try it under Linux.

comment:5 Changed 16 years ago by fingolfin

Did you reproduce this with exactly this save game? If yes, can you try this:
load the save game, leave via the tunnels, re-enter the room, then save
again (as a new savefile). Then try if you can reproduce the bug with that
new savegame.
Just want to exclude any save game weirdnesses (although I don't think
that's a likely cause).

comment:6 Changed 16 years ago by fingolfin

Yeah well folks, I still can't reproduce this. As long nobody replies
to my questions, and/or proofs this is an actual bug by creating a
new, independant save game that also exhibits this problem, I'll
consider this is a broken savegame.

comment:7 Changed 16 years ago by fingolfin

Status: newpending

comment:8 Changed 16 years ago by eriktorbjorn

Status: pendingnew

comment:9 Changed 16 years ago by eriktorbjorn

(Sorry, I meant to answer before.) Right now I can't seem to
reproduce it at all. But when I did, it was with the
original savegame.

I'm inclined to agree with you. If whever caused the problem
is still in the CVS trunk, it'll resurface again eventually.
(Probably a few days after the next stable release. ;-)

comment:10 Changed 16 years ago by eriktorbjorn

Status: newpending

comment:11 Changed 16 years ago by eriktorbjorn

What the...? I can't remember re-opening the bug report!

comment:12 Changed 16 years ago by fingolfin

That's an automatic feature. "Pending" is a special state (see also
the help text avaiable via the little question mark next to
"Status:". It marks a bug as "pending response from somebody".
If no response comes withing some preset time, it'll automatically
be closed (or deleted? forgot). Otherwise, as soon as any activity
is registered, it automatically reverts to open (hence even though
I didn't touch the status, submitting this would re-open it... but
now I will change the status, to closed :-)

comment:13 Changed 16 years ago by fingolfin

Owner: set to fingolfin
Resolution: worksforme
Status: pendingclosed
Note: See TracTickets for help on using tickets.