Opened 16 years ago

Closed 16 years ago

#811 closed defect (invalid)

MI2: Missing sound effects

Reported by: SF/itsr0y Owned by: SF/jamieson630
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

In the latest CVS version, some sound effects don't
work in MI2. The easiest one to find is in the
copy-protection. In the 0.4.0 release, there is sound
as the pictures change, but no sound is in the CVS
version. Also, when the woodsmith hammers, there
should be sound, but there is none in the latest CVS.

Ticket imported from: #743285. Ticket imported from: bugs/811.

Change History (6)

comment:1 Changed 16 years ago by SF/jamieson630

Priority: normallow

comment:2 Changed 16 years ago by SF/jamieson630

What command line options/configuration options used to run
it.

You must run MI2 either with -eadlib to hear the sound
effects, or if you are using a native driver (e.g. -eseq or -
ewindows), you must also specify --multi-midi in order to hear
the Adlib-only sound effects.

Lowering priority -- I suspect this is not a bug.

comment:3 Changed 16 years ago by SF/jamieson630

Owner: set to SF/jamieson630

comment:4 Changed 16 years ago by SF/itsr0y

I was using -ewindows. When i switched to adlib, it worked
again. I guess this changed since 0.4.1?

Thanks, and sorry about that.

comment:5 Changed 16 years ago by SF/jamieson630

Resolution: invalid
Status: newclosed

comment:6 Changed 16 years ago by SF/jamieson630

I'm not aware that we were ever forcing -eadlib on someone
who tried to run MI2 with -ewindows, but I don't know. If you
want to enjoy the higher-quality -ewindows music but still
hear the Adlib sound effects, just use the --multi-midi
command line option (or the multi_midi=true config option).

Note: See TracTickets for help on using tickets.