Opened 17 years ago

Closed 17 years ago

Last modified 12 months ago

#8107 closed patch

M1VGA stump joke (unkMessage2) - FIX

Reported by: SF/doren Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

Hi,

Here's a diff file for an implementation of unkMessage2 (I
assume that the message is to be displayed in a small
one-line dialog).

I would have liked the dialog to match the width of the
string to be displayed, but this would require
including "newgui.h" from "strings.h", which seems like
a bad idea. Pay attention to the comment there.

Use with patch -p 0

David Oren

Ticket imported from: #628574. Ticket imported from: patches/212.

Attachments (3)

stump.patch (3.2 KB ) - added by SF/doren 17 years ago.
stump2.patch (1.8 KB ) - added by SF/doren 17 years ago.
stumpfix.patch (589 bytes ) - added by SF/doren 17 years ago.

Download all attachments as: .zip

Change History (21)

by SF/doren, 17 years ago

Attachment: stump.patch added

comment:1 by fingolfin, 17 years ago

Owner: set to fingolfin

comment:2 by fingolfin, 17 years ago

Thanks David, this look fine. But for the string width, well, no worries:
my suggestion would be that the InfoDialog computes its desired width.

I.e. it's no problem to change _w in the constructor. So, InfoDialog would
only take the string, no x/y/w/h coords. Then it could use a fixed height
(we just always assume 1 line), and calculate the x pos & width based
on the string width. If you want try to do it this way, otherwise I'll look
into it later today.

by SF/doren, 17 years ago

Attachment: stump2.patch added

comment:3 by SF/doren, 17 years ago

Ok, here it is...

David

comment:4 by fingolfin, 17 years ago

Status: newclosed

comment:5 by fingolfin, 17 years ago

Patch contained a syntax error. In th future please submit patches using
the "-u" options that makes it a bit easier; also trying to follow the code
layout rules ScummVM uses (e.g. no space after function calls, so not
"sin ()" but rather "sin()" etc. makes it more likely for a patch to be
accepted (since we then don't have to clean it up).
But otherwise the patch looks nice and solid! Will put it in now

comment:6 by SF/doren, 17 years ago

Oh, sorry. Yesterday was a long and difficult day...

You're right about the syntax error (no idea how it got there), and
about the -u option (which I usually use, but forgot last night).

And next time I'll pay more attention to coding style.

comment:7 by SF/andrej4000, 17 years ago

Now it has to be hacked away in Loom and Dig....

(If not done already....)

by SF/doren, 17 years ago

Attachment: stumpfix.patch added

comment:8 by SF/doren, 17 years ago

Status: closednew
Summary: M1VGA stump joke (unkMessage2)M1VGA stump joke (unkMessage2) - FIX

comment:9 by SF/doren, 17 years ago

As you can see, there are complaints that this breaks
something in Loom and Dig. I haven't got either of these
games, so I can't verify it myself.

But to be on the safe side, here's a patch that checks
whether we are running M1VGA or not (as far as I know, this
jokes has been removed in the CD version, so there's no point
checking for that as well).

David

comment:10 by fingolfin, 17 years ago

Interesting, I see the problem in Dig, but what gets broken in Loom?

comment:11 by fingolfin, 17 years ago

Status: newclosed

comment:12 by SF/ender, 17 years ago

What problem in The Dig? I removed the "Too little memory"
message some time ago...

There is no problem in Loom either, in fact unkMessage2 is
-used- in Loom to display the informational 'subtitle' message.
Theres no reason for us NOT to display this message, it's in the
script and we should thus be as faithful to it as possible.

I'd recommend removing the MI1VGA check again.

comment:13 by SF/doren, 17 years ago

As I've said, I've never seen either of these games, so I really
don't know what the problem is -- andrej4000 will probably know
what the problem was, since he was the one to mention it...

Just a thought: when Loom displays 'subtitle' messages, is the
user expected to press a key for the game to continue? If not, the
implementation of unkMessage2 in M1VGA and Loom should be
different.

comment:14 by SF/ender, 17 years ago

Yes, the user is.

As I said, there IS no problem with Loom and the mivga only
patch should (imho) be reversed.

andre, can you either clarify your problem.... or can fingolfin
please reverse this patch... :)

comment:15 by SF/andrej4000, 17 years ago

the last time i started loomvga
the message showed up "Press F9 to turn subtitles ..."
But this was nonsence, since ScummVM didn't show or
hide the text.
This was only used in the original interpreter.
In ScummVM (correct me if i'm wrong) these messages are
withot function and should be hacked away, if not used.

comment:16 by SF/ender, 17 years ago

Definatly not!

Unless the message is something totally insane, like the memory
warnings, we should always prefer to implement the feature -
never remove or hide original game functionality instead of it!

comment:17 by SF/andrej4000, 17 years ago

ok, then just go and implement it! :)

btw: i didn't mean to supress this comman in all of the
games, but only in the beginning of loomvga and it's "F9"-
message... anyway, you should implement this function into
the game.

comment:18 by digitall, 12 months ago

Component: Engine: SCUMM
Game: Monkey Island 1
Note: See TracTickets for help on using tickets.