Opened 18 years ago

Closed 18 years ago

Last modified 2 years ago

#793 closed defect (fixed)

INDY3: plane disapears on game loading

Reported by: SF/hibernatus Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Indiana Jones 3

Description

ScummVM 0.4.1cvs Built on May 20 2003 13:35:27 under WinXP

This bug is not annoying at all. But we never know, it could reveal another one :)

When you fly the biplane and if you save/load, the plane may reappear out of the screen. Somletimes it does, sometimes it doesn't. When it does, the game still works well but it's pretty hard to have the plane come back into the screen.

Ticket imported from: #740473. Ticket imported from: bugs/793.

Attachments (1)

indy3.s13 (40.1 KB ) - added by SF/hibernatus 18 years ago.
3 seconds before flying :)

Download all attachments as: .zip

Change History (10)

by SF/hibernatus, 18 years ago

Attachment: indy3.s13 added

3 seconds before flying :)

comment:1 by eriktorbjorn, 18 years ago

Very odd. In case the savegame doesn't work (I don't think it does for the German version, for instance), using the debugger to go to room 80 might work just as well.

comment:2 by eriktorbjorn, 18 years ago

Is this still broken? I couldn't reproduce it with today's CVS snapshot, but I only made a few attempts.

If it's fixed, I have no idea what did it though.

comment:3 by fingolfin, 18 years ago

The question is, can you reproduce the problem if you start playing the game from scratch, not using any old "polluted" save games?

Or asked the other way around, when did you create your various save games? Recently? 1 month ago? 2 months? 3, 4, 5, 6 ... ?

comment:4 by eriktorbjorn, 18 years ago

I can reproduce it more often than not with the debugger trick mentioned below, if I use a snapshot from two days ago. I haven't been able to reproduce it with today's snapshot. Not yet at least.

comment:5 by SF/hibernatus, 18 years ago

My oldest save game (in the begining of the game) was made on 05/19. So it's very recent. I don't feel like making a new one now. Maybe i (you?) could play the whole game with a software that records all the mouse/kb input and plays it back.

comment:6 by SF/hibernatus, 18 years ago

I've just tried the last version with my save game and the bug is gone.

comment:7 by fingolfin, 18 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:8 by fingolfin, 18 years ago

Hrm, no idea what fixed this, but oh well, I won't complain ;-)

comment:9 by digitall, 2 years ago

Component: Engine: SCUMM
Game: Indiana Jones 3
Note: See TracTickets for help on using tickets.