Opened 18 years ago

Closed 18 years ago

Last modified 12 months ago

#79 closed defect (fixed)

Music speed problems

Reported by: SF/drebon Owned by: SF/ender
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

The Music of the intro scene of Monkey 2 starts too
late (there is no sound while the LA logo is displayed
and it only starts when the monkeys are dancing since
a few seconds). By the way the music is too slow (at
least 1.2x too slow) and this is for all the games I
tired (I use scummvm-0.1.0-win32)

Ticket imported from: #522125. Ticket imported from: bugs/79.

Change History (20)

comment:1 by SF/drebon, 18 years ago

Owner: set to SF/ender

comment:2 by SF/ender, 18 years ago

Hi drebon,
I'm not aware of any speed problems with MI2. It's mostly
likely due to a bug with your midi sequencer. I will do
some further testing on some test machines later tonight,
but you might want to try it on a friends machine and see
if he has the same problem.

comment:3 by SF/drebon, 18 years ago

I just tried it on an other computer and the problem
stills... May it comes from a diffrent version of the
game ? The intro music starts too late (approx 12 sec too
late) and is too slow...
The speed problem is in all the games I tried (monkey 2
dott indy 4) They all are in French Version...
I should maybe try to find other version and check if it
is the same....

comment:4 by SF/ender, 18 years ago

Very odd. DOTT works fine for me. Best I can do is suggest
you wait for the next release, and see if there are still
problems with it.

comment:5 by SF/ender, 18 years ago

Hmm, seen a few other reports of the same thing. It might
just be that particular .exe.

I'll post one I know works for you to test, later tonight.

comment:6 by SF/ender, 18 years ago

Summary: Monkey 2 intro music wrong delayMusic speed problems

comment:7 by SF/ender, 18 years ago

http://www.enderboi.com/scummvm.zip

Try that and let me know if it helps.

comment:8 by SF/drebon, 18 years ago

Well it may be a bit better (it seems quite ok for indy 4
but I do not know that game well so I do not know the
correct timing...) but for DOTT and Monkey 2 the problem is
still there...

The music of the intro is too slow, during the game also
and for Monkey 2 the music starts too late : it begins when
the monkeys are dancing since 10-15sec...
It is the same on another computer...

I alos tried the italian version of Monkey 2 and it is the
same...

comment:9 by SF/ender, 18 years ago

Very unusual. I tested it with DOTT, Sam and Max and
Indy4... I don't have Monkey2 handy.

With all of the above my timing was perfect. This is on a
PIII-350 laptop with some crappy generic SB16 compatible
soundcard.

Sorry, I can't think of anything else to help..

comment:10 by SF/pkirlin, 18 years ago

I'm experiencing a similar problem with Indiana Jones and
the Fate of Atlantis. The intro music is too slow -- it's
definitely noticeable. The background music when the
actual game starts is also too slow.

comment:11 by SF/drebon, 18 years ago

Well I think we should detail our version of scummvm and
the version of the game we are using... so I give you the
crc of the files :
name crc size
scummvm.exe 5ec1ce3b 240 640
scummvm.exe* f0b47880 495 661 * other version
with same pb
SDL.dll 498c042f 225 280
atlantis.000 e2837671 12 030 French
atlantis.001 20da0911 9 705 940 French
monkey2.000 876218a1 11 135 French
monkey2.001 e93eba9f 9 115 980 French
tentacle.000 6fd97ddd 7 932 French
tentacle.001 905bd3ee 11 300 378 French
monkey2.000 8b35e6f5 11 135 Italian
monkey2.001 2dbf081a 9 097 092 Italian

All this games have the same problem with the both
version of the exec I displayed here, (except maybe for
indy 4 wich I do not really know so I cannot say what
should be the correct timing...)

comment:12 by SF/ender, 18 years ago

Well, my SDL.dll is different, but that's because mine I
compiled myself (are you using the latest version of SDL?)

I use the english talkie version of DOTT, so my filesizes
are again different:

7,932 TENTACLE.000
11,358,470 TENTACLE.001

As I said, both Indy4 and Sam and Max sound fine to me, so
I'm not sure - unless it's a problem with the translations..

comment:13 by SF/drebon, 18 years ago

Well I verified and I had the ltest version of SDL...
well I really do not know where does it comes from...
But there is a point I would like to know, you said it
could come from a problem with my midi sequencer, but when
I turn the midi off the music still there... Is this really
midi sound ? I don't think so...
And well are you really sure the musics have the perfect
timing on your computer ? Because except for monkey 2 where
there's a big delay for the intro music, for the other
games it is more difficult to notice it because of the
imuse system wich keeps a correct following of the musics...
so if you want I could upload a version of Monkey 2 in
order to see if you have the same bug.. and have you got a
good working pure dos mode with sound ? if yes I suggest
you to compare the speed of the musics under the real game
and under scummvm...
And if you have a version of windows without any dos
mode, I suggest you to visit that site.. sorry it is in
french, but you'll find there an utility to make a DOS 6.22
boot disk for every windows (including XP) and then you'll
just need to have your DOS drivers for your soundcard...
thank you.

comment:14 by SF/drebon, 18 years ago

Priority: normalhigh

comment:15 by SF/drebon, 18 years ago

I belive a good idea would be to add a command line
parameter to choose the music playback speed in percents of
the actual... something like scummvm monkey2 -s 103
in the forums section someone answered me this :
"You can change the TEMPO_BASE define in imuse.cpp - I like
it when set to 1F0000 :) " unfortunately I'm talented for
compiling anyting.. so I am not really able to try this...
but I think a commanf line parameter would be a good
solution to fix that problem...
Thank you.

comment:16 by SF/ender, 18 years ago

Ok, if you recompile from the latest CVS there is now a -t
commandline option to set your music speed.

Normal would be:
scummvm -t1647840 monkey2

I will be adding a GUI to scummvm shortly allowing you to
change things such as this.

If you can't compile, a pre-compiled copy is here:
http://www.enderboi.com/scummvm.exe

Let me know what value works.

comment:17 by SF/drebon, 18 years ago

Tahnk you very much ! It works well, I think a correct
speed would be something like -t1900000 it seems to be
allmost perfect on my computer with this ...
Thanks...

comment:18 by SF/ender, 18 years ago

cool. closing.

comment:19 by SF/ender, 18 years ago

Resolution: fixed
Status: newclosed

comment:20 by digitall, 12 months ago

Component: Engine: SCUMM
Game: Monkey Island 2
Note: See TracTickets for help on using tickets.