Opened 6 years ago

Closed 16 months ago

#7860 closed enhancement (wontfix)

BASS: Keep multiple auto-saves

Reported by: SF/inguin Owned by: dafioram
Priority: normal Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

I've just played through Beneath a Steel Sky for the first time, and I had to replay large parts because the game decided to auto-save in an irrecoverable situation:

- In the first case Joey and Rob stood vis-a-vis in a narrow doorway, with neither being able to move (sounds like bug #1314495)
- In the second case the game was saved right before the android in the secret cloning facility killed me. I'll try to reproduce that and file a separate bug report.

Since both problems sound like game data issues and are probably not easily fixable in ScummVM I'd like the game to keep the last two or three auto-saves instead. That way, when you find yourself in a hopeless situation you could always go back to a previous snapshot and only replay a few minutes instead of (worst case) the whole game.

Ticket imported from: #3613952. Ticket imported from: feature-requests/676.

Change History (2)

comment:1 Changed 17 months ago by csnover

Component: Engine: Sky
Game: Beneath a Steel Sky

comment:2 Changed 16 months ago by dafioram

Owner: set to dafioram
Resolution: wontfix
Status: newclosed

Players should use the save game feature rather than relying strictly on the autosave.

Note: See TracTickets for help on using tickets.