Opened 7 years ago

Closed 22 months ago

#7851 closed enhancement (wontfix)

SCI: QFG1VGA - missing magic menu during combat

Reported by: misterhands Owned by: wjp
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Quest for Glory 1

Description

QFG1 VGA
SCUMMVM 1.6.0git2002-g76ff4c7 Win 64

The problem is that a Fighter character doesn't have access to the alternate/magic menu during combat.
If you try to call it using the 5 key on the numpad, or by clicking on the star icon at the center, ego stops fighting and runs.
A Thief character (and of course a Magic user) on the other hand works correctly : you have the main combat menu
and you can switch to the magic menu, even if you have the Magic attribute to 0 and have no spell at all.
Also to run you normally have to select the RUN action, not the central icon.

There is no restriction in the game on creating a fighter that can cast spells, but being unable to actually use them in combat kind of makes it useless and makes no sense.

What's more, the game manual states that all 3 classes can access the magic menu. See the pic of the relevant page I have uploaded. In the archive you will also find 2 savegames at the Goblin central combat training zone, one Thief, one Fighter, for easy comparison. "Use" the bush to enter combat.

The original interpreter behaves exactly the same way so this is probably yet_another_script_bug, and a major one IMO.
So it would be nice if the SCI team could investigate this issue and make one of those magic script patches for it !

Thank you

Ticket imported from: #3578745. Ticket imported from: feature-requests/667.

Attachments (1)

QFG1VGA.zip (240.9 KB ) - added by misterhands 7 years ago.

Download all attachments as: .zip

Change History (10)

by misterhands, 7 years ago

Attachment: QFG1VGA.zip added

comment:1 by SF/captainjei, 7 years ago

I think that you can't cast spells in combat because you're carrying a shield. And I believe the VGA version of QfG1 doesn't let you drop the shield. I remember pressing '5' to run a way when I played as a fighter on my 386 back in the 90's.

comment:2 by misterhands, 7 years ago

Well that's possible, and indeed, you cannot drop the shield.
Still, it's annoying that you can't cast spells as a fighter even though you have magic and spells.
And again, the manual says that you can, so unless it is incorrect, there might be a bug here.
We'll see what the devs say about this.

comment:3 by SF/captainjei, 7 years ago

Yeah, the manual for the VGA remake is a bit misleading, since it shows an 'alternate' menu, and there's nothing in the game that or manual that I know of that specifically tells you you need a free hand to cast spells.

In the EGA version of QFG1, if you try casting a spell in combat while carrying a shield, it tells you you need a free hand to make the arcane gestures needed to cast a spell.

The rest of the games in the series are mostly consistent about this, except for QFG4, which lets a fighter or paladin cast spells while holding a shield.

comment:4 by digitall, 7 years ago

Keywords: original added; script removed

comment:5 by bluegr, 7 years ago

This is more fitting to be a feature request, as it's a bug in the original game scripts or the manual. I'm changing it to be a feature request instead, as this isn't a bug in ScummVM itself, and it's something that would require quite a lot of effort to implement correctly, in order to properly change the game behavior for this menu.

Moving to feature requests

comment:6 by bluegr, 7 years ago

Component: Engine: SCI
Game: Quest for Glory 2
Keywords: original removed

comment:7 by tomasz89, 3 years ago

I don't know if I agree with this feature request. I think it goes against the design intent and I don't see it as a buggy script.

The fighter already has strong combat skills, they'd be way overpowered if they had magic too (during combat, anyway). I think the screen shot you refer to is from a pre-release of the game, and the manual was probably written based off early intent too - a common way of parallelising the tasks in software development.

If this is implemented, I would strongly suggest it should be at best an optional/toggleable feature.

comment:8 by csnover, 23 months ago

Component: Engine: SCI
Game: Quest for Glory 1

comment:9 by wjp, 22 months ago

Owner: set to wjp
Resolution: wontfix
Status: newclosed

I think this is too invasive a change to the mechanics of the game to be in scope for ScummVM.

Note: See TracTickets for help on using tickets.