Opened 12 years ago

Closed 8 months ago

#7806 closed feature request (fixed)

TOON: add support for speech/subtitle/both options

Reported by: SF/hmilchuser Owned by: antoniou79
Priority: normal Component: Engine: Toon
Version: Keywords:
Cc: Game: Toonstruck

Description

The option for speech/subtitle/both is ignored by the game. In the game there are always speech AND subtitle and you can not turne off one of them.

SCUMVM-Version: 1.3.0svn55526 OS: Windows XP / Game-Version: DE

Best Regards Thomas

Ticket imported from: #3166525. Ticket imported from: feature-requests/622.

Change History (6)

comment:1 by bluegr, 12 years ago

Component: Engine: Toon
Game: Toonstruck
Summary: TOON: option speech/subtitle/both has no effectTOON: add support for speech/subtitle/both options

comment:2 by bluegr, 12 years ago

Support for the ScummVM speech/subtitles dialog is a missing feature, not a bug. Moving to the appropriate tracker

comment:3 by tsoliman, 12 years ago

I realize you're talking about the GUI dialog, but pressing the in-game hotkeys works for me in English version

comment:4 by csnover, 5 years ago

Component: Engine: Toon
Game: Toonstruck

comment:5 by antoniou79, 8 months ago

If anyone has time to test, and can build from the source code, this PR is meant to address this issue --the PR is not merged to the master branch yet:
https://github.com/scummvm/scummvm/pull/3954

comment:6 by antoniou79, 8 months ago

Owner: set to antoniou79
Resolution: fixed
Status: newclosed

The PR completing this feature request is now merged with master branch and backported to 2.6.0.

One thing to note is that the user can select to have only speech or only text, but they cannot disable both. If they try to disable both, the game will force enable subtitles. This matches the behavior of the original game, and also fixes an original bug whereby there was a case that the game would actually disable subtitles and speech (using the respective hotkey shortcuts while in-game) and characters would appear as frozen when speaking.

Thank you for the report.

Note: See TracTickets for help on using tickets.