Opened 9 years ago

Closed 9 years ago

Last modified 12 months ago

#7789 closed enhancement (duplicate)

Both text and speech in SQ4

Reported by: SF/l-w-c Owned by:
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Space Quest 4

Description

The unofficial v1.2 of SQ4 offers text and speech at the same time.- http://sourceforge.net/tracker/?func=detail&aid=3088944&group_id=37116&atid=418820

However, unlike what you said there (to which I can't reply, v1.2 did NOT remove the copy protection. The OFFICIAL CD version removed it itself! You even confirmed this in the forums.

So v1.2 or not, can you add support for both text and speed? It really causes a headache to play with just speech. And without speech, you're missing a lot.

Ticket imported from: #3088984. Ticket imported from: feature-requests/605.

Change History (7)

comment:1 by bluegr, 9 years ago

Once again, there wasn't any official patch 1.2 for sq4 by Sierra itself. As I said, it is a fan made patch that changes a lot of things in the game and contains files from the original game to do this. Here is the link to the unofficial patch:

http://spacequest.wikia.com/wiki/Space_Quest_4_CD_Version_Update

Quote: "Space Quest 4 update for the CD-ROM version (5.3 MB) This excellent update, developed by "New Rising Sun" contains the following improvements for the CD-ROM version of SQ4:"

NewRisingSun is a fan, there was never an official patch by Sierra.

"Installation instructions: With the replacement of nearly every single graphics resource, the usual "patch" distribution method is inadequate; instead, the full game, minus the audio file, is included"

This "patch" contains the majority of the floppy version files, as I said. For now, we are not going to support it for legal reasons. I'll leave the request open for now, in case someone else feels differently about this, or unless we find a way to patch the original game scripts for simultaneous text anf sxtipt support

comment:2 by bluegr, 9 years ago

Sorry, typo: simultaneous text and speech support (writing from an iphone)

comment:3 by m-kiewitz, 9 years ago

This artifact has been marked as a duplicate of artifact 3037737 with reason:
same feature

comment:4 by m-kiewitz, 9 years ago

Status: newclosed

comment:5 by m-kiewitz, 9 years ago

Space Quest 4 CD has the copy protection disabled, yes. But that "patch" is actually almost full Space Quest 4 Floppy - but w/o copy protection.

The patch would only be legal, if it just took files from a SQ4 floppy installation and put it into the SQ4 cd directory - which would actually mean that one would have to actually own both versions of the game. Instead the patch is actually a cracked version of Space Quest 4 floppy and we won't support that.

Anyway, closing this because the feature was already requested for all CD talkie editions.

comment:6 by m-kiewitz, 9 years ago

Resolution: duplicate

comment:7 by digitall, 12 months ago

Component: Engine: SCI
Game: Space Quest 4
Note: See TracTickets for help on using tickets.