Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#776 closed defect (wontfix)

MI1: game crashes in scummbar

Reported by: SF/tollak Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

monmey island 1 the white label bubble pack version
scummvm version 0.4.0 date 2003-05-11

there is no music and the game crasches when entering
the scummbar with the error
error room 28 not in 28 at 1342104+0 in file monkey.001

Ticket imported from: #738869. Ticket imported from: bugs/776.

Change History (9)

comment:1 Changed 16 years ago by fingolfin

Summary: game chash scummbarMI1: game crashes in scummbar

comment:2 Changed 16 years ago by fingolfin

So you are starting the game with the "monkey" target (as opposed to
monkeyvga)?
Is this an english version? With Audio CD tracks?

To clarify your bug description, is this what you are doing:
1) Launch ScummVM with "monkey", i.e.
scummvm monkey
2) Once the intro finished, walk to the scumm bar
3) Open door
4) Enter
5) Crash

comment:3 Changed 16 years ago by SF/tollak

Is this an english version? With Audio CD tracks? Yes

To clarify your bug description, is this what you are doing:
1) Launch ScummVM with "monkey", i.e.
scummvm monkey
i start scummvm select monkey island 1 (alt)
2) Once the intro finished, walk to the scumm bar
3) Open door
4) Enter
5) Crash
yes

comment:4 Changed 16 years ago by SF/tollak

more
when the game starts it says
trying to start game monkey island 1 (alt) version 5.2.2
i also tried to go to the town then i get room 35 not in 35 at
1899191+0 in file monkey1.001 so i cannot leave the earea
where the game starts if i do the game chrashes

comment:5 Changed 16 years ago by eriktorbjorn

I can't reproduce this. Could the data files have become
corrupted somehow, or are there several different English CD
versions of MI1?

comment:6 Changed 16 years ago by SF/tollak

the cover of the cd is white the picture looks like a stap and
shows monkey islan 1 and 2 below is a white label stamp
and a lucasarts logo the music is audio tracks and thay play
find i had to try and old pc i had a p200mmx and the game
runs fine without scummvm so the ploblem seems to be in
scummvm dont know how many versions of mi there are i
only knows 2 different cd versions one with cd audio and one
without mine is with audio tracks

comment:7 Changed 16 years ago by eriktorbjorn

I just remembered... According to the README, there's a
known problem with ScummVM under Windows if you try to play
a game from CD that also plays music from the CD. Is this
what you are doing? If so, try copying the data files to
your hard disk and play them from there.

I always play the game from hard disk, with Ogg
Vorbis-encoded audio tracks, and usually under Linux, so I
keep forgetting about this bug. (I never even understood if
the bug is in ScummVM, SDL, Windows, or somewhere else.)

comment:8 Changed 16 years ago by fingolfin

Quoting our README:

"If you are experiencing random crashes, and your game plays music
from CD, you have encountered a Windows bug. Try copying the data
files from CD to your hard disk, and running them from there."

comment:9 Changed 16 years ago by fingolfin

Owner: set to fingolfin
Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.