Opened 10 years ago

Closed 9 years ago

Last modified 11 months ago

#7709 closed enhancement (fixed)

AGI: Proper Tandy 3-Voice/IBM PCjr Sound Support

Reported by: SF/musiclyinspired Owned by: sev-
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game:

Description

Currently, the sound support in AGI plays back the 3-channel sound resources plus the white noise but it sounds awful (perhaps because the Sarien interpreter was originally meant to imitate the Amiga?). The voices sound very Amiga-like (sort of like a bad electric piano Casio keyboard sound) and the white noise is just a bland hiss without pitch-shifting capabilities. Since ScummVM currently has the ability to produce proper IBM PCjr sound for SCUMM games would it be difficult to move the same capabilities over to the AGI engine as well? NAGI (another AGI interpreter) and DOSBox (when machine type is set to "tandy") both produce the proper sound if reference is needed.

Ticket imported from: #2813133. Ticket imported from: feature-requests/525.

Change History (6)

comment:1 by sev-, 9 years ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

comment:2 by sev-, 9 years ago

Implemented in SVN. Now it is default mode for DOS games. Old emulator is left for Amiga and Atari.

comment:3 by SF/musiclyinspired, 9 years ago

It seems that the PCjr music mode is no longer set to default for DOS AGI games. It has to be set manually. Can this be reset to PCjr as default?

comment:4 by sev-, 9 years ago

It is not a feature request but a regression. Could you please post a bugreport? I just don't have time right now and may just forget about it in the future. Feel free to assign it to myself

comment:5 by SF/musiclyinspired, 9 years ago

Certainly.

comment:6 by digitall, 11 months ago

Component: Engine: AGI
Note: See TracTickets for help on using tickets.