Opened 10 years ago

Last modified 7 months ago

#7685 new enhancement

SYMBIAN: Port to UIQ 2.1

Reported by: SF/robin71 Owned by: anotherguest
Priority: normal Component: Port: Symbian
Keywords: Cc:
Game:

Description

Why don't support UIQ 2.1?

Ticket imported from: #2595410. Ticket imported from: feature-requests/501.

Change History (7)

comment:1 Changed 10 years ago by fingolfin

Could you elaborate a bit? Like, what *is* UIQ 2.1, and what devices use it? AFAIK, it is some kind of GUI used by some Symbian OS based phones, but I am not sure. But even if it is right: Is that kind of a new version? Or an old one? Or what?

In general, though, porting to new versions of a system can be a difficult task, so the answer to your questions just might be "because nobody had the time yet". And for old versions of a system, the answer often is "because it can't work on that system". But I know too little to say whether the answer is any of these.

Maybe anotherguest wants to comment on this, he's our Symbian porter.

comment:2 Changed 10 years ago by fingolfin

Owner: set to anotherguest
Summary: SCUMVM 0.12 for UIQ 2.1SYMBIAN(?): Port to UIQ 2.1

comment:3 Changed 10 years ago by SF/robin71

Yes, Symbian UIQ 2 is supported only until at 0.9.1. Why not 0.12.0????? There are many device with Symbian UIQ 2.
Thanks.

comment:4 Changed 5 years ago by digitall

Summary: SYMBIAN(?): Port to UIQ 2.1SYMBIAN: Port to UIQ 2.1

comment:5 Changed 5 years ago by anotherguest

Biggest reason for not supporting UIQ2 devices, is that the compiler support is not there in that platform. To build 0.9.1 a lot of patching needed to be done, and today it would even more patching required, if at all possible. With Symbian OS 9 and later (on which UIQ3 and S60vx is based on) we have a newer compiler tool chain which we can build ScummVM with.

comment:6 Changed 19 months ago by csnover

Component: Ports

comment:7 Changed 7 months ago by digitall

Component: PortsPort: Symbian
Note: See TracTickets for help on using tickets.