Opened 16 years ago

Closed 16 years ago

#767 closed defect (fixed)

SAM: Part of text (subtitles) disappears when moving mouse

Reported by: SF/evil_penguin Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

In Sam&Max's office if you get Sam (and Max?) to stand
behind the table and try to use Max on the TV antenna
(or probably anything else that would get the subtitles
in the same position.. if there is any other such
object) and move the mouse cursor while the text ("I
can't use these things together") is displayed part of
the text disappears! (Upper left corner.)

The positioning of Sam is quite critical it seems, but
it's easily reproducible for me (but takes a little
trial and error sometimes).

I just happened to stumble upon this one, and thought
it might have worse effects somewhere else, if it is a
"real bug".

Verified with ScummVM 0.4.0 and current CVS
(2003-05-14) on (GNU/)Linux... (SDL 1.2.5).

Ticket imported from: #737387. Ticket imported from: bugs/767.

Attachments (3)

samnmax_textbug.png (64.6 KB) - added by SF/evil_penguin 16 years ago.
Screenshot showing the glitch
samnmax_textbug2.png (63.0 KB) - added by SF/evil_penguin 16 years ago.
Second screenshot showing the glitch
samnmax_textbug3.png (46.0 KB) - added by SF/evil_penguin 16 years ago.
Screenshot in other room

Download all attachments as: .zip

Change History (13)

Changed 16 years ago by SF/evil_penguin

Attachment: samnmax_textbug.png added

Screenshot showing the glitch

Changed 16 years ago by SF/evil_penguin

Attachment: samnmax_textbug2.png added

Second screenshot showing the glitch

comment:1 Changed 16 years ago by SF/evil_penguin

Summary: Part of text (subtitles) disappears when moving mouse cursorSAM: Part of text (subtitles) disappears when moving mouse

Changed 16 years ago by SF/evil_penguin

Attachment: samnmax_textbug3.png added

Screenshot in other room

comment:2 Changed 16 years ago by SF/evil_penguin

Just for the sake of clearness... The same thing happens in
other rooms too. (Added third screenshot)

comment:3 Changed 16 years ago by fingolfin

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed

comment:4 Changed 16 years ago by SF/evil_penguin

Status: closednew

comment:5 Changed 16 years ago by SF/evil_penguin

Reopening as problem persists...
(Current CVS)

comment:6 Changed 16 years ago by SF/evil_penguin

Further explanation: Much easier to reproduce as in
....textbug3.png (using Max on the stairs up and moving the
mouse while text is visible.)

comment:7 Changed 16 years ago by eriktorbjorn

The problem is with our implementation of useIm01Cursor().
See patch #738100 for more details.

To clarify a bit further, it's not the moving of the cursor
that causes the problem. It's when the cursor changes to
Max's head with a red outline. Since this is the cursor you
already have when you cause the text to be drawn, you have
to move the cursor so that it changes to the non-outlined
version and back again.

I haven't checked, but I imagine the same thing can happen
with some (but not all, apparently) other cursors as well.
Perhaps it's just the ones you get when using an object with
another?

comment:8 Changed 16 years ago by SF/evil_penguin

Yes, now that you say it... and I look at it again, that is
exactly when it happens.

I can also verify that your patch eliminates the problem.

comment:9 Changed 16 years ago by fingolfin

Status: newclosed

comment:10 Changed 16 years ago by fingolfin

Fixed for real this time, then ;-) Sorry for the previous confusion.

Note: See TracTickets for help on using tickets.