Opened 16 years ago

Closed 16 years ago

#764 closed defect (fixed)

DIG: Savegame/Island names

Reported by: SF/inguin Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

I'm just playing "The Dig" for the first time in ScummVM and I just noticed a strange bug: I saved my game two days ago after talking to the entombed alien for the first time and restored it today. I then noticed that when walking across the light bridges all islands lost their explicit names and are just called "Insel". The only exception is the vault island on which I saved the game.
Further, all doors in the nexus are now displayed as "verschlossene Tür", meaning "locked door". That doesn't keep me from walking through them, though.
I attached the savegame in question, I hope it's compatible with the english version. Anyway, since the bug doesn't seem to affect gameplay I'm gonna set it to low priority.

Ticket imported from: #734154. Ticket imported from: bugs/764.

Attachments (1)

dig.s01.gz (34.7 KB ) - added by SF/inguin 16 years ago.
The Dig (german) savegame, ScummVM 0.3.7cvs

Download all attachments as: .zip

Change History (6)

by SF/inguin, 16 years ago

Attachment: dig.s01.gz added

The Dig (german) savegame, ScummVM 0.3.7cvs

comment:1 by SF/inguin, 16 years ago

Priority: normallow

comment:2 by SF/inguin, 16 years ago

Great, Sourceforge rejected my savegame for being 10k too large. I'm gonna try it again, this time gzip'ed.

comment:3 by SF/mditri, 16 years ago

I can reproduce this bug with today's CVS and the english
version too.

comment:4 by fingolfin, 16 years ago

Owner: set to fingolfin
Priority: lownormal
Resolution: fixed
Status: newclosed

comment:5 by fingolfin, 16 years ago

Uh this bug is so embarassing =). We weren't storing the
_newNames array. Ouch. Fixed now.

Note: See TracTickets for help on using tickets.