Opened 12 years ago

Closed 12 years ago

Last modified 13 months ago

#7596 closed enhancement (wontfix)

PALM: Memory leaks and misuse

Reported by: SF/eduardo-costa Owned by: SF/chrilith
Priority: normal Component: Port: PalmOS
Keywords: Cc:
Game:

Description

I read that PalmOS backend does not work in Zire 71 and others because of limited heap. After some "dig" into the source code, I have a bug/feature request:
1. Use MemHandleNew instead of MemPtrNew
2. Use MHN or MPN instead of malloc

Since ScummVM for PalmOS uses a lot of "new" operations (which are based on "malloc"), Palm Memory Manager will never defragment memory.

Ticket imported from: #1825272. Ticket imported from: feature-requests/412.

Change History (5)

comment:1 by fingolfin, 12 years ago

Owner: set to SF/chrilith

comment:2 by fingolfin, 12 years ago

This is not a bug, rather a "feature request"

Furthermore, while I am not that familiar with PalmOS coding, I believe this change would be far from trivial.

comment:3 by SF/chrilith, 12 years ago

Resolution: wontfix
Status: newclosed

comment:4 by SF/chrilith, 12 years ago

Hi,

I'm sorry to say that this is not possible :(
In fact, MemHandleNew requires a memory lock/unlock system which is not implemented in any of the ScummVM engines. So, it will require lots of modification and will be a serious issue regarding performance.

new operator is not really based on malloc... anyway my malloc implementation is based on MemPtrNew/MemChunckNew and
defragmentation occured only on PalmOS for MemHandles and only if they are unlocked.

comment:5 by digitall, 13 months ago

Component: Port: PalmOS
Note: See TracTickets for help on using tickets.