Opened 12 years ago

Closed 11 years ago

Last modified 11 months ago

#7594 closed enhancement (fixed)

SYMBIAN: Screen rotation on UIQ3 ("lefty flip")

Reported by: SF/teetow Owned by: anotherguest
Priority: normal Component: Port: Symbian
Keywords: Cc:
Game:

Description

This applies to any ScummVM version running on a device with a touchscreen. In my case, this is a Sony Ericsson P1i UIQ3 device.

A left-handed player cannot simultaneously use the keypad and hold the stylus in his left hand. Also, the ergonomics of having to reach across the keypad to play the game is somewhat strenuous.

Suggestion is to implement a lefty-flip toggle, where the landscape mode is rotated so that the game is played with the keypad on the right-hand side.

Ticket imported from: #1817100. Ticket imported from: feature-requests/410.

Change History (8)

comment:1 by SF/teetow, 12 years ago

Summary: Screen rotation on UIQ3 ("lefty flip")SYMBIAN: Screen rotation on UIQ3 ("lefty flip")

comment:2 by bluegr, 12 years ago

Component: --Unset--

comment:3 by bluegr, 12 years ago

This is not a bug per se, but a feature request

Moving this to the feature requests section

comment:4 by fingolfin, 12 years ago

Owner: set to anotherguest

comment:5 by anotherguest, 11 years ago

Implemented in the SDL backend with Scummvm 0.12.0

comment:6 by anotherguest, 11 years ago

Resolution: fixed

comment:7 by sev-, 11 years ago

Status: newclosed

comment:8 by digitall, 11 months ago

Component: Port: Symbian
Note: See TracTickets for help on using tickets.