Opened 12 years ago

Closed 11 years ago

Last modified 13 months ago

#7577 closed enhancement (fixed)

BS1: Add cutscenes addons localizations in flac format

Reported by: SF/paletta Owned by: sev-
Priority: normal Component: Engine: Sword1
Keywords: Cc:
Game: Broken Sword 1

Description

The cutscenes for Broken Sword 1 here:
http://sourceforge.net/project/showfiles.php?group_id=37116&package_id=90616

are missing the addon localizations in flac format.

Ticket imported from: #1739042. Ticket imported from: feature-requests/393.

Change History (18)

comment:1 by fingolfin, 12 years ago

I don't think those are "missing" Until yesterday, BS1 did not even support playback of FLAC audio. Even now it's unclear to me whether we should release a FLAC version. At most, this would be a feature request.

comment:2 by fingolfin, 12 years ago

Owner: set to fingolfin
Resolution: invalid
Status: newclosed

comment:3 by SF/paletta, 12 years ago

Resolution: invalid
Status: closednew

comment:4 by SF/paletta, 12 years ago

(Note: I was building a BS1 package from my original CDs for use with the yet to be released 0.10.0)

The ogg version should be for older than 0.10.0 scummvm, where the cutscenes where encoded in MPEG2+ogg, while from 0.10.0 are DXA+FLAC.

The README file of 0.10.0 branch:
http://svn.sourceforge.net/viewvc/scummvm/scummvm/branches/branch-0-10-0/README?revision=27530&view=markup
says:
398 These cutscenes are provided in DXA format with FLAC audio. Their quality
399 is equal to the original games due to the use of lossless compression.
400 Viewing these cutscenes requires a version of ScummVM compiled with both
401 FLAC and zLib support.

So I suppose that BS1 with 0.10.0 support FLAC audio, at least for cutscenes (and I hope music/*, but not tried yet), while flac in .clu files are supported only in post 0.10.0 (the svn log mention scummvm-tools so, it should the flac support in .clu files).

So I downloaded the file Sword1_DXA_Cutscenes.zip , which contains some .dxa (video) and .fla (shouldn't be .flac?) files.
I also downloaded my addon locale, but it contains the audio in .ogg and not flac as in Sword1_DXA_Cutscenes.zip .

comment:5 by sev-, 12 years ago

Yes, FLAC is supported in cutscenes. To use langpacks do following: extract langpack into directory with DXA cutscenes and then remove .fla files if there is corresponing .ogg one. This will make ScummVM load localized voiceovers.

As of reencoding language packs in FLAC, we can't do it in most cases simply because we don't have access to those versions. Most of those packs were contributed by our users.

comment:6 by sev-, 12 years ago

Yes, FLAC is supported in cutscenes. To use langpacks do following: extract langpack into directory with DXA cutscenes and then remove .fla files if there is corresponing .ogg one. This will make ScummVM load localized voiceovers.

As of reencoding language packs in FLAC, we can't do it in most cases simply because we don't have access to those versions. Most of those packs were contributed by our users.

comment:7 by SF/paletta, 12 years ago

I'd like to contribute the italian flac files. How can I get these? I tried encode_dxa (scummvm-tools 0.9.0 build from source under a Fedora 7) but I get a segfault:

$ ./scummvm-tools-0.9.0/encode_dxa --flac --best -b 1152 /mnt/cd2/smackshi/ferrari
Width = 640, Height = 400, Framerate = -8333, Frames = 441
Segmentation fault

comment:8 by SF/paletta, 12 years ago

I managed to convert the smk files into wav (with a recent ffmpeg) and then into flac (with flac-1.1.4):
$ ffmpeg -i /mnt/cd2/smackshi/finale.smk finale.wav
$ flac --best -b 1152 --lax *wav

I can send you the flac files, if you want.

comment:9 by eriktorbjorn, 12 years ago

> I don't think those are "missing" Until yesterday, BS1 did not even
> support playback of FLAC audio.

Yesterday's change was for the BS1 music. The cutscenes already use Audio::AudioStream::openStreamFile(), which I believe handles all the compression formats automagically.

comment:10 by fingolfin, 12 years ago

Yes I stand corrected on that, sorry for the mix up on my part :-(.

comment:11 by fingolfin, 12 years ago

But this is nevertheless a request for enhancement, not a bug report :-).

comment:12 by fingolfin, 12 years ago

Component: Engine: Sword1
Game: Broken Sword 1
Summary: Missing cutscenes addons localizations in flac formatBS!: Add cutscenes addons localizations in flac format

comment:13 by SF/paletta, 12 years ago

You can download the Italian FLAC cutscenes here:
http://rapidshare.com/files/38674211/Sword1_FLAC_Cutscenes_ITA_AddOn.zip.html

comment:14 by SF/paletta, 12 years ago

You can download the Italian FLAC cutscenes here:
http://rapidshare.com/files/38674211/Sword1_FLAC_Cutscenes_ITA_AddOn.zip.html

comment:15 by fingolfin, 12 years ago

Owner: fingolfin removed
Summary: BS!: Add cutscenes addons localizations in flac formatBS1: Add cutscenes addons localizations in flac format

comment:16 by sev-, 11 years ago

Done.

comment:17 by sev-, 11 years ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

comment:18 by digitall, 13 months ago

Component: Engine: Sword1
Game: Broken Sword 1
Note: See TracTickets for help on using tickets.