Opened 16 years ago

Closed 16 years ago

#757 closed defect (fixed)

ZAK256: Some verbs do not highlight correctly

Reported by: SF/doc_wagon Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

Sometimes, some of the verbs do not highlight if the
mouse cursor is over them.

Check the savegame of bug 732412: ZAK256: Bug with
Alien Machine (Outro)

If you move the mouse over the first three verbs (push,
open, walk to), they won't highlight.

Using ScummVM CVS from May 4th.

Ticket imported from: #732414. Ticket imported from: bugs/757.

Attachments (1)

zak256a.s08 (55.3 KB) - added by SF/doc_wagon 16 years ago.
zak256 savegame

Download all attachments as: .zip

Change History (7)

comment:1 Changed 16 years ago by fingolfin

Confirmed, happens here very often even with newly started games;
selecting those verbs with their shortcuts doesn't work either.

comment:2 Changed 16 years ago by fingolfin

I can't reproduce this anymore in latest CVS; note that your
savegame might still be broken, of course... can you reproduce
this still with latest CVS, and starting a "clean" game?

comment:3 Changed 16 years ago by SF/doc_wagon

I just tried it (with a 'clean' new game) and it still seems to
happen. Attached a savegame in the shop where the "buy"
and "sell" verbs do not highlight correctly. I had the game
in "pause" state for quite some time (1-2 hours) maybe this
has something to do with it?

Changed 16 years ago by SF/doc_wagon

Attachment: zak256a.s08 added

zak256 savegame

comment:4 Changed 16 years ago by fingolfin

Indeed I can reproduce the problem even by starting a new game
then going straight to the shop. Thanks, that should help a lot in
tracking it down & finding a fix.

comment:5 Changed 16 years ago by fingolfin

Owner: set to fingolfin

comment:6 Changed 16 years ago by fingolfin

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.