Opened 16 years ago

Closed 16 years ago

#756 closed defect (fixed)

ZAK256: Bug with Alien Machine (Outro)

Reported by: SF/doc_wagon Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

In the end cutscene, we see the two aliens standing in
front of their machine, saying something like "oh-oh
that's not good..."
The machine has a horizontal gauge, and the bug is
that the indicator of the gauge moves in from the left
side of the screen, painting a white stripe over the
background, before it starts acting like it should.

Also, I think the two aliens are not supposed to
disappear that quickly, they're just gone and then the
machine is destroyed. I think that's all happening a bit
too fast but I didn't check it with another version of Zak.

Savegame attached, just "push lever", "switch to
annie", "push lever", then wait.

Ticket imported from: #732412. Ticket imported from: bugs/756.

Attachments (1)

zak256a.s07 (43.4 KB) - added by SF/doc_wagon 16 years ago.
Savegame

Download all attachments as: .zip

Change History (7)

Changed 16 years ago by SF/doc_wagon

Attachment: zak256a.s07 added

Savegame

comment:1 Changed 16 years ago by SF/doc_wagon

btw, I'm using ScummVM CVS from May 4th.

comment:2 Changed 16 years ago by fingolfin

I think the gauge works correct with latest CVS, could you check?

As for the aliens vanishing too quickly: yeah, the script tries to trigger
a special "fade" (or rather, screen effect) which we don't currently
implement. If you have any clue what's supposed to happen here in the
original, please tell me. (e.g. maybe a flash or so?)

comment:3 Changed 16 years ago by fingolfin

Owner: set to fingolfin

comment:4 Changed 16 years ago by SF/doc_wagon

Confirmed. Gauge works now.

Sorry, I can't tell what's supposed to happen in the original
Zak256 since I don't have a FmTowns Machine. But I *could*
play through one of the other Zaks (either DOS or C64
version) and try to record a movie clip from them if that
helps...

comment:5 Changed 16 years ago by fingolfin

Resolution: fixed
Status: newclosed

comment:6 Changed 16 years ago by fingolfin

Thanks. Such a movie clip would be nice, although it doesn't
necessarily reflect what happens is supposed to happen the FMtowns
version (which after all has "spiced up" graphics). Still if you could
provide such a movie, would be nice :-)

Note: See TracTickets for help on using tickets.