Opened 13 years ago

Closed 13 years ago

Last modified 10 months ago

#7497 closed enhancement (duplicate)

MACOSX: Make Bundle Ignores ./configure

Reported by: SF/powerofjurai Owned by: fingolfin
Priority: low Component: Port: Mac OS X
Keywords: Cc:
Game:

Description

While performing 'make' takes into account set
directories of ./configure switches, 'make bundle' does
not appear to and will cause failed compilations until
the MAKEFILE is modified by hand to resolve the issue.
Particular guilty code:

OSXOPT=/opt/local/
# Special target to create a static linked binary for
Mac OS X.
# We use -force_cpusubtype_ALL to ensure the binary
runs on every
# PowerPC machine.
scummvm-static: $(OBJS)
$(CXX) $(LDFLAGS) -force_cpusubtype_ALL -o
scummvm-static $(OBJS) \
`sdl-config --static-libs` \
-framework CoreMIDI \
$(OSXOPT)/lib/libmad.a \
$(OSXOPT)/lib/libvorbisfile.a \
$(OSXOPT)/lib/libvorbis.a \
$(OSXOPT)/lib/libogg.a \
$(OSXOPT)/lib/libmpeg2.a \
$(OSXOPT)/lib/libflac.a \
-lSystemStubs \
-lz

perhaps it could be modfiied to use the LIBS defined
after running ./configure and specifying lib locations
using with-lib-prefix= ?

Ticket imported from: #1503965. Ticket imported from: feature-requests/313.

Change History (6)

comment:1 Changed 13 years ago by fingolfin

Component: --Unset--
Summary: Make Bundle Ignores ./Configure (OSX)MACOSX: Make Bundle Ignores ./configure

comment:2 Changed 13 years ago by fingolfin

The "make bundle" target is an hack, and intentionally so. I don't consider this a
bug, but rather a feature request for a more stable "bundle" target. Moving to
the appropriate tracker.

comment:3 Changed 13 years ago by fingolfin

Priority: normallow

comment:4 Changed 13 years ago by fingolfin

Duplicate of FR #1327285.

comment:5 Changed 13 years ago by fingolfin

Owner: set to fingolfin
Resolution: duplicate
Status: newclosed

comment:6 Changed 10 months ago by digitall

Component: Port: Mac OS X
Note: See TracTickets for help on using tickets.