Opened 15 years ago

Closed 15 years ago

Last modified 2 years ago

#7483 closed enhancement (duplicate)

[Windows] scummvm.ini is in the wrong position

Reported by: SF/angalla Owned by: Kirben
Priority: normal Component: Port: Win32
Keywords: Cc:
Game:

Description

INI file is in the wrong position for these reasons:

1) I could not create a CD with an already made configuration that can works on every computer. If I could create an ini file and put in the same dir as exe, i can run games that are burned on the same CD/DVD. 2) Windows is a protected directory, no program should use it. Only admins can work there. Use profile instead.

A solution could be a search path, in this order. 1) local dir (same as exe) 2) %APPDATA%\ScummVM 3) %WINDIR%

And 2 should be the default configuration dir. Thanks!

Ticket imported from: #1460153. Ticket imported from: feature-requests/299.

Change History (7)

comment:1 by sev-, 15 years ago

Ugh, it _should_? Please, provide patch which will be portable accross all Windows platforms that we support, including Windows 9x. Thanks.

comment:2 by sev-, 15 years ago

Status: newpending

comment:3 by Kirben, 15 years ago

Status: pendingclosed

comment:4 by Kirben, 15 years ago

Closed as duplicate of feature request #743288.

This isn't a problem that can easily be solved, without breaking compatbility with earlier Windows versions.

comment:5 by Kirben, 15 years ago

Owner: set to Kirben
Resolution: duplicate

comment:6 by Kirben, 15 years ago

Also you could solve the issue of running ScummVM off a CD, by using the '-c' command line option to set an alternative config file. With a batch file or shortcut, to launch ScummVM.

comment:7 by digitall, 2 years ago

Component: Port: Win32
Note: See TracTickets for help on using tickets.