Opened 14 years ago

Closed 14 years ago

Last modified 21 months ago

#7482 closed enhancement (wontfix)

Extrapath and sub folders

Reported by: SF/mikkoa Owned by: Kirben
Priority: normal Component: --Other--
Keywords: Cc:
Game:

Description

I noticed that the "extrapath" configuration doesn't support sub folders.

I need to put files to the root of the extrapath folder, ScummCM doesn't find them if they're in video\ or data\

Since ScummVM supports multiple game entries per game, it's handy to put common files to the extrapath folder. But because ScummVM doesn't support subfolders the folder structure gets messed up (= lost) when files are put to the root.

Ticket imported from: #1450918. Ticket imported from: feature-requests/298.

Change History (8)

comment:1 by Kirben, 14 years ago

Status: newclosed

comment:2 by Kirben, 14 years ago

Rejected, as the extra path setting can already be set differently for each game under ScummVM.

comment:3 by Kirben, 14 years ago

Owner: set to Kirben
Resolution: wontfix

comment:4 by SF/mikkoa, 14 years ago

Thanks for the quick reply and yes you're right, ScummVM supports per game extrapath settings. But, ScummVM doesn't support file lookup from the respective folders with extrapath.

For example:

If I have a data file in DATA\ROADRASH.RIP it doesn't work if moved to extrapath\DATA\ROADRASH.RIP.

FileMon shows that ScummVM tries to look from the following locations:

game folder\ROADRASH.RIP game folder\DATA\ROADRASH.RIP game folder\VIDEO\ROADRASH.RIP extrapath\ROADRASH.RIP

ScummVM doesn't try extrapath\DATA\ROADRASH.RIP and fails with the following error message:

Trying to start game 'Full Throttle' File::size: File is not open!!

.. which could be a bit more descriptive.

Adding a few lookups to the code which locates the files would make this scenario work and adding filename information to the error message would help in troubleshooting.

The reason why I'm requesting this is following: I have two versions of Full Throttle, the other has for some reason or another more video and data files. If they're set up to different folders the files take about 910MB. If the common files are moved to the extrapath folder, the size is reduced to about 550MB.

Right now this is possible, but the extrapath folder can't contain the files in their own sub folders which messes up the folder structure.

comment:5 by SF/mikkoa, 14 years ago

Status: closednew

comment:6 by fingolfin, 14 years ago

There is no reason at all to preserve the folder structure. Anyway, what you are trying to do is beyond the purpose of "extrapath". So this is not a bug -- at best it would be a feature request...

comment:7 by fingolfin, 14 years ago

Component: --Unset--
Status: newclosed

comment:8 by digitall, 21 months ago

Component: --Other--
Note: See TracTickets for help on using tickets.