Opened 14 years ago

Closed 8 years ago

Last modified 12 months ago

#7450 closed enhancement (wontfix)

FM-TOWNS: Enable aspect ratio correction

Reported by: SF/vood Owned by: sev-
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

Aspect ratio correction cant be enabled in fm-towns
games. I believe fm-towns original screen resolution was
320x240, but anyway lucas ports still used the original
320x200 resolution, so even in the original computer
they had black bars and a streched image. Fortunatly
we can solve this in scummvm, but for some strange
reason (probably the aspect correction routine doesn´t
know what to dos with an original 320x240 screen), It
doesnt work.

Ticket imported from: #1326700. Ticket imported from: feature-requests/266.

Attachments (2)

fm_default_aspect_ratio.jpg (39.1 KB ) - added by SF/vood 14 years ago.
Thats how it looks
fm_correct_aspect_ratio.jpg (43.4 KB ) - added by SF/vood 14 years ago.
Thats how it should look

Download all attachments as: .zip

Change History (17)

by SF/vood, 14 years ago

Attachment: fm_default_aspect_ratio.jpg added

Thats how it looks

by SF/vood, 14 years ago

Attachment: fm_correct_aspect_ratio.jpg added

Thats how it should look

comment:1 by SF/vood, 14 years ago

Summary: Aspect ratio correction not working at allFM-TOWNS:Aspect ratio correction not working at all

comment:2 by eriktorbjorn, 14 years ago

ScummVM only knows how to stretch 320x200 images, and their
multiples, 640x400 and 960x600. The version 3 FM Towns games
(Indy 3, Loom and Zak, I believe) use 320x240, so they can't
be stretched.

Now, I don't own any of these games (and probably never
will) so I have no idea why this is, or whether or not they
actually *use* the extra 40 pixels for anything. But I am
fairly sure that this is the reason you can't use aspect
ratio correction on them.

comment:3 by sev-, 14 years ago

Aspect ratio correction appeared because it really took
place on hardware. I.e. 320x200 isn't 4:3 so it was scaled
by factor of 1.2. FM-TOWNS natively ran in 640x480 and LEC
320x200 graphics was padded to 320x240. Afaik some games
even used lower 40 pixels too.

Yes, our aspect ratio correction turns on only if screen
height is exactly 200, i.e. it just doesn't apply for
FM-TOWNS'es 240. (TOWNS comes from last name of some
scientist Townes, so it's singular)

Though I don't know should we really reject this item. At
least this is not a bug but a feature request. Moving it
there and lowering priority as all other FM-TOWNS stuff.

comment:4 by sev-, 14 years ago

Component: Engine: SCUMM
Game: Zak McKracken
Priority: normallow
Summary: FM-TOWNS:Aspect ratio correction not working at allFM-TOWNS: Enable aspect ratio correction

comment:5 by fingolfin, 14 years ago

ZakTowns uses more than 200 pixels. It uses the added space
to show more inventory (good idea, and was fairly easy to
implement for them, too). Interestingly, it doesn't seem to
use all the 240 pixels, though -- about 20-25 pixels at the
bottom stay black. I am not sure if those are ever used in
the game...

There are two possible "solutions" to the whole issue, I
think: 1) Allow activating the aspect ratio correction for
320x240 games, too. The result would be 320x288, which
wouldn't fit on many small screen devices. 2) Try to cut
down the game to 320x200. In the case of ZakTowns, that
would imply the game inventory needs to be restricted in
size, probably the same for Indy3.

I have no idea at all how Monky Island on FM-TOWNS works,
though -- everything I said here might be moot for that...

comment:6 by SF/vood, 14 years ago

Well, I mostly play on a window, (and I guess many other
people also), so I think allowing an optional aspect ratio
correction wont make any hurt.

comment:7 by SF/logicdeluxe, 14 years ago

Unlike Zak McKracken, Indy 3 does not have the extended
inventory, ie. there are only 3 lines, exactly like the PC
VGA version.
It would make perfectly sense, just running the game at
320x200 instead of 320x240, I'd say.
You still could just disable aspect ratio correction, if you
prefer the squeezed image, then.

comment:8 by SF/zorbid, 10 years ago

I'm not sure the aspect correction is important for these games anyway (except maybe for Indy4).

The graphics of Scumm games up to MI2 (and maybe later) were drawn with square pixels in mind. This is very noticeable in the Zak intro (the earth is ovoid with aspect correction, and round without) and in the first Largo scene in MI2 (Guibrush becomes short and fat when Largo holds him above his head with aspect correction but keeps normal proportions without).

comment:9 by SF/timarg, 10 years ago

zorbids statement confused me somewhat, so I had to check it...
Actually (and quite logically) it is the exact opposite of what zorbid said. Without aspect ratio correction the earth in the Zak intro is ovoid, with enabled aspect ratio correction it is an (almost) perfect circle.
So aspect ratio correction IS important for FM Town too. Without it, you have to play them without correction. The earth in the intro is just as ovoid in the Town Zak as in the PC Zak with disabled apect ratio correction.

I don't think it would be very hard to do. Just cut off the black bar at the bottom and/or crop the inventory to the size of the original version.

I'd really appriciate that feature, because the FM Towns version of Zak is definitely the best one, but you can't play it with the correct aspect ratio for now.

comment:10 by sev-, 8 years ago

After giving this a second thought, I am rejecting this request. The original games were intended to be squashed.

comment:11 by sev-, 8 years ago

Owner: set to sev-
Resolution: wontfix
Status: newclosed

comment:12 by SF/vood, 4 years ago

Ouch..11 years later, and I still disagree with the decision taken. Yes, FM-Towns originally showed the image squashed but only because there was no way to use the correct aspect ratio in that hardware. Keeping in mind the correct aspect ratio is the PC one I can't see why an optional option to correct it in FM-Towns could'nt be included.

One could argue ScummVM is trying to keep itself as faithful as possible to the original source...but then why games have options like HQ or SAI filters? Those were not avaible in the original versions and they change the image much more radically than a simple aspect ration change.

In my opinion a simple cropping of the unused black space plus aspect ratio correction would improve A LOT FM-Towns games.

Please reconsider it.

Thanks in advance.

comment:13 by lukeman3000, 3 years ago

Sev, I think you should give this more consideration.

While I understand your point about the games originally being this way, this, as you said, could be a feature and most certainly an optional one at that. So of course it would not be forced upon the user.

Furthermore, as SF/Vood said, other options in ScummVM alter the appearance of games to a much higher degree than stretching the image out a few pixels (in my opinion).

I think it's worth revisiting this, but that's just my two cents. I would love to see this feature in ScummVM.

comment:14 by spiffythedog, 3 years ago

I've really got to agree with vood and lukeman3000 here, especially after reading this old forum thread: http://forums.scummvm.org/viewtopic.php?t=5663

This would make for an absolutely incredible enhancement (even if it were purely optional), and only requiring some simple cropping/modification in the case of Loom and Zak McKracken. I mean, the visuals are clearly (and needlessly) distorted when displayed at the default 320x240 resolution, and the only reason Sev provides for not implementing such a fix is that these games were somehow 'intended to be squashed,' despite all the available evidence indicating the exact opposite?

It's no wonder people are dissatisfied with this decision.

comment:15 by digitall, 12 months ago

Component: Engine: SCUMM
Note: See TracTickets for help on using tickets.