Opened 14 years ago

Closed 12 years ago

Last modified 13 months ago

#7439 closed enhancement (fixed)

BS1: Invert stereo channels for traffic sounds in Rue Jarry

Reported by: SF/helh Owned by: eriktorbjorn
Priority: normal Component: Engine: Sword1
Keywords: original Cc:
Game: Broken Sword 1

Description

Concerning Broken Sword 1:

This is a problem I've already experienced with the
original game, so it is nothing ScummVM specific, but
it could be fixable with ScummVM.

In Rue Jarry, in front of Nico's apartment, you can see
cars passing by on the left side of the scene,
accompanied by some stereo sounds of them passing by.

The problem is, whenever a car or truck/lorry passes
by, the sound goes in the opposite direction. So when a
car passes by from left to right, you hear a sound of a
car passing by from right to left, exactly opposite to
what you see. Same with the trucks.

Some time ago I thought this was a problem with my
setup, but this is not the case, in every other program
I've tested the channels aren't inverted. Even tested
this on two different computers.

I've tried three different versions:

Original German Version
German Sold-Out Version
English Sold-Out Version

Every one of them has the same issue with these
inverted traffic sounds. And of course there's no
difference with ScummVM.

First of all, could someone confirm this kind of "sound
bug"? I don't think this is an issue only present in
those three versions.

Secondly, this would be easily(?) fixable by inverting
the left and right channel of those sounds in this scene.

If it isn't possible to change sounds for just one scene,
I think it wouldn't even make a difference to invert
those sounds globally, as there aren't any other scenes
where you can see AND hear cars passing by as far as I
can remember.
These traffic sounds are at least used again inside
Nico's appartment and in front of Hotel Ubu though.

Ticket imported from: #1266599. Ticket imported from: feature-requests/255.

Change History (8)

comment:1 by fingolfin, 14 years ago

Owner: set to eriktorbjorn

comment:2 by fingolfin, 14 years ago

Torbjörn, any oppinion on this? (please un-assign yourself, unless you are
interested in working on this :-).

comment:3 by fingolfin, 12 years ago

Patch #1833038 supposedly addresses this, but I haven't reviewed it (yet). Torbjörn... ? *g*

comment:4 by eriktorbjorn, 12 years ago

It's hard for me to say - my speakers are pretty close together - but it does seem like the "Truck passes, left to right" and "Truck passes, right to left" sound effects have been mixed up. I wonder if this is the only place where these effects are used to illustrate something that's visible on screen. If so, the simplest way to fix it should be to swap them in _fxList[] in staticres.cpp.

comment:5 by SF/helh, 12 years ago

eriktorbjorn: I guess the same applies to the cars, not only the trucks. I for one didn't notice any other scenes where you can actually see cars/trucks passing by...

comment:6 by eriktorbjorn, 12 years ago

I've committed my patch to the trunk. (Not the branch, since it's a feature request.)

comment:7 by eriktorbjorn, 12 years ago

Resolution: fixed
Status: newclosed

comment:8 by digitall, 13 months ago

Component: Engine: Sword1
Game: Broken Sword 1
Keywords: original added
Note: See TracTickets for help on using tickets.