Opened 16 years ago

Closed 16 years ago

#741 closed defect (fixed)

MI2: text not completely erased after scrolling

Reported by: SF/schneiper Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

Hi,

Problem 1: I have play the game from begin to end an i
get tow or tree times a graffic error with my Guybrush.
I can´t describe it. Look at the picture. (testet with
version 0.3.0b)

Problem 2: On a scrolling room, spoken text scroll with
the background and will not delete partly. I hope
anybody understand me ;-)
At the savegame (Dinky Island), walk so that Polly is
on the right side of the sceen. Now Polly say something
an you go to the right screen and a part of the text
will scroll to left. The result can you see on the
picture. (testet with version 0.3.0b up to 0.3.7cvs)

- Version: ScummVM 0.3.7cvs Built on Apr 27 2003 20:15:54
- Language: German Version
- Gameversion: MI2 Floppy German Version
- Platform: Win98SE
- Savegame attached to problem 2 and tree screenshots
to all problems

mfg Schneiper

Ticket imported from: #728424. Ticket imported from: bugs/741.

Attachments (1)

gfx-bugs.zip (118.3 KB) - added by SF/schneiper 16 years ago.
1 Savegame and 3 Screenshots

Download all attachments as: .zip

Change History (19)

Changed 16 years ago by SF/schneiper

Attachment: gfx-bugs.zip added

1 Savegame and 3 Screenshots

comment:1 Changed 16 years ago by fingolfin

Summary: MI2: 2 graffic errorsMI2: two graphic errors

comment:2 Changed 16 years ago by SF/ursg

A similar bug occurs in FOA (German version, Non-Talkie at
least):
Actors leave "traces" when walking across the screen.
This appears to happen only in a small area on the left side.

Screenshots:
http://www.namensraumverschmutzung.net/~urs/indy4bug.png
http://www.namensraumverschmutzung.net/~urs/atlantis.s19.png
Savegame:
http://www.namensraumverschmutzung.net/~urs/atlantis.s19
(Walk around in front of the big box and you'll leave traces)

This bug is reproducable for me (Linux/SDL port)

comment:3 Changed 16 years ago by SF/schneiper

I think the problem is the text should removed from the
screen befor scrolling begin and not after the picture
scroll the first part.

comment:4 Changed 16 years ago by fingolfin

ursg's problem turned out to be caused by a bad CVS build, and is
gone. Your first bug looks suspiciously similar...

Do you compile CVS yourself or do you use the dialy built binaries we
provide?

Since I don't have the german MI2, I can't try that save game. But no
the text should not be removed before the scrolling begins, rather it
should be scrolled correctly :-)

comment:5 Changed 16 years ago by SF/schneiper

Hi,

i have testit again.

I cant adjust Problem1 with this smal test.

Problem2 was NOT in v0.3.0b (last non CVS) but in many CVS
builds up to 0.3.7cvs Built on Apr 27 2003. I can adjust too
by Kaptn Kate at Booty Island.

comment:6 Changed 16 years ago by fingolfin

What do you mean with "adjust" here? This sounds like an improper
translation from German, although being German myself I still don't
understand it :-) (BTW http://dict.leo.org is a really great online
dictionary).

Did you want to say: You still get Problem 1. Or did you mean You do
not get it anymore?

comment:7 Changed 16 years ago by SF/schneiper

hmmmmmm

What i mean is...
In a smal test, i do not get it again Problem1.

comment:8 Changed 16 years ago by fingolfin

First does, this still happen with the very latest CVS?

Sadly I can't open that german save game. Hm, maybe you can tell me the
room number. Press "#" key to get into the debugger, then enter the "room"
command - this will tell you the room number. One can then "teleport" to
that room by using "room NUMBER".

If you tell me the room number on Dinky Island, maybe I can teleport there
and reproduce the bug this way.

comment:9 Changed 16 years ago by fingolfin

Status: newpending

comment:10 Changed 16 years ago by SF/schneiper

Status: pendingnew

comment:11 Changed 16 years ago by SF/schneiper

Hi,

the roomnumber is 85 (Dinky Island) but i cant "teleport"
in this room.
The same bug exist on Booty Island, in front of Stans Shop,
when Kaptn Kate talking and the screen scrolling.

mfg Schneiper

comment:12 Changed 16 years ago by fingolfin

You still didn't tell us if this is with latest CVS, though.

comment:13 Changed 16 years ago by SF/schneiper

Hi,

i have tested again with...
ScummVM 0.4.2cvs
Built on Jun 8 2003 10:48:38
...and the bug exist in this CVS.

mfg Schneiper

comment:14 Changed 16 years ago by fingolfin

Summary: MI2: two graphic errorsMI2: text not completely erased after scrolling

comment:15 Changed 16 years ago by eriktorbjorn

I've seen the scrolling text problem appear in other cases
as well. (I have a savegame at home that demonstrates it in
FOA, for instance.)

I noticed our setCameraAt() function will call stopTalk() in
some cases (shouldn't that be restoreCharsetBg() instead, or
do we really want the actor to stop talking as well?) but I
don't think that's enough to catch all cases, e.g. when the
camera pans or follows an actor.

Perhaps that should be in cameraMoved() instead, but I don't
know...

comment:16 Changed 16 years ago by fingolfin

I made a change to cameraMoved which updates gdi._mask
when the camera moves, fixing a similar problem in The Dig. I
wonder if that helps here, too?

Erik, the stopTalk() is there in the original,too, at least for V1-V3
games. I don't have access to V5+ disassmbly right now, so i
can't tell if they do it, too. But note, ScummVM was based on a
V5 game, so it's likely to be correct there, too. Since V7/V8 uses
a separate version of setCameraAt(), that only leaves V6 games -
maybe there stopTalk() really shouldn't be called. Dunno.

comment:17 Changed 16 years ago by SF/schneiper

Yes it works fine! The problem is fixed. Who must close this
bugmessage?

comment:18 Changed 16 years ago by fingolfin

Owner: set to fingolfin
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.