Opened 15 years ago

Closed 15 years ago

Last modified 13 months ago

#7408 closed enhancement (wontfix)

Scale to 1280x1024 resolution

Reported by: SF/filamento Owned by: sev-
Priority: normal Component: Graphics: Scalers
Keywords: Cc:
Game:

Description

Hi,

I have a 19" LCD monitor which has a physical 5:4
screen aspect ratio and a resolution of 1280x1024 pixels.

This resolution is very popular among 17" and 19" LCD
displays, but is currently not supported by scummvm.

Could you please add support for this resolution?

And, please, when you scale the image to fit the entire
screen, make sure that you maintain the proper aspect
ratio for which the games were designed (4:3).

That means that those of us that are using a 5:4
resolution will have to suffer small black borders at
the top and bottom of the screen. But I'm OK with that:
it's the small price we have to pay in order to have
the correct aspect ratio.

Regards.

Ticket imported from: #1152965. Ticket imported from: feature-requests/224.

Change History (8)

comment:1 by fingolfin, 15 years ago

We don't have any plans to add a 4x scaler at this time.

Most LCDs allow scaleing up graphics, though, so you could play with the
2x scaler at 640x480 and let your display/OS do the additional 2x
upscaling.

comment:2 by SF/filamento, 15 years ago

Yes, I can do that, but the problem is that my monitor
destroys the aspect ratio because it scales to fill the
entire screen and stretches too much the image vertically :(

Also, my monitor isn't very good at scaling (the image is
horribly blurred)

So, I beg you please to reconsider this feature request.
Perhaps label it "low priority" or something, but please
don't discard it!

Kind regards.

comment:3 by sev-, 15 years ago

There should be some checkbox in you monitor properties
which disables stretching.

4x scalers bloat code a lot except simplest Normal4x but
that definitely will look worse than your current picture.

Such request was raised many times before and we even got
already ready-to-apply patches, still we continue to reject
it for above reasons.

Fingolfin, reject it again?

comment:4 by SF/filamento, 15 years ago

Hi sev,

Unfortunately, there's no such checkbox in my system :(
I'm using Windows XP SP2 with a Radeon 9600 XT (latest
drivers) and a Dell 1905FP monitor connected to the DVI port.

There's a checkbox in ATI drivers called "Scale image to
panel size", but, sadly, unchecking it does nothing.

The monitor will always scale to full size (both vertically
and horizontally), destroying the proper aspect ratio in the
process.

Could you do something similar to what M.A.M.E. (the arcade
emulator) does in their Windows version?
MAME works perfectly for me, because the image is scaled to
1280x1024 (or whatever resolution I choose) and the aspect
ratio is preserved correctly.
Or maybe you could do it like DosBox (a dos emulator).
DosBox also lets you specify a fixed full screen resolution
of your choice, and it will maintain the aspect ratio.

But, please, don't reject it. There are more and more people
buying LCD monitors these days. And all the 17" and 19"
monitors I've seen use a 5:4 native resolution!

Thanks again.
Best regards.

comment:5 by SF/khalek, 15 years ago

There is already an option to specify the original aspect ratio.
Scaling to an arbitary resolution is not something we can do
effectively without giving you a lot of black borders.

I think this should be closed.

comment:6 by sev-, 15 years ago

Owner: set to sev-
Resolution: wontfix
Status: newclosed

comment:7 by sev-, 15 years ago

As it was discussed many times we aren't going to add 4x
scalers. They bloat code siginificantly and userbase is very
little. I think this hsould go to FAQ. Rejecting.

comment:8 by digitall, 13 months ago

Component: Graphics: Scalers
Note: See TracTickets for help on using tickets.