Opened 15 years ago

Closed 14 years ago

Last modified 13 months ago

#7386 closed enhancement (invalid)

WINCE/BASS: Support PocketPC with screen protector

Reported by: SF/kralikba Owned by: SF/arisme
Priority: normal Component: Port: WinCE
Keywords: Cc:
Game: Beneath a Steel Sky

Description

I'm really sorry for not having submitted a full
description. This is a bug, because as far as I know, not
my PDA is the only one, which wont allow you to move
the cursor to the topmost part when using landscape
mode. It has a screen protector on. So I do not know,
how this can be solved.

Ticket imported from: #1030237. Ticket imported from: feature-requests/202.

Change History (15)

comment:1 by fingolfin, 15 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:2 by SF/kralikba, 15 years ago

The version was 0.6.1b
To reproduce it, simply start the game, turn the display to
landscape mode, and try to tap the uppermost row with your
stylus. As my PDA has a screen protector, taps are less
accurate.
It is an English floppy BASS
The platform is Pocket PC-ARM, a Dell Axim X3i, the compiler
is what you used when compiling the binaries, I do not know
its version.
No save game is needed, as it can be reproduced anywhere
in the game.

comment:3 by fingolfin, 15 years ago

So this is a WinCE specific problem, it seems?

comment:4 by fingolfin, 15 years ago

Owner: set to SF/arisme
Summary: No inventoryWINCE: No inventory

comment:5 by SF/kralikba, 15 years ago

I think it is a PDA-with-screen-protector-specific problem.

comment:6 by fingolfin, 14 years ago

Summary: WINCE: No inventoryBASS/WINCE: No inventory

comment:7 by fingolfin, 14 years ago

Component: Engine: Sky
Game: Beneath a Steel Sky

comment:8 by sev-, 14 years ago

What is the status of this item?

comment:9 by fingolfin, 14 years ago

Does it work when you remove the screen protector?

comment:10 by SF/kralikba, 14 years ago

Yes, it does, that is why I said: PDA-with-screen-protector-
specific problem.

comment:11 by fingolfin, 14 years ago

Component: Engine: Sky
Game: Beneath a Steel Sky
Summary: BASS/WINCE: No inventoryWINCE/BASS: Support PocketPC with screen protector

comment:12 by fingolfin, 14 years ago

Ah. So this isn't really a bug. Rather, you are using a device which is
crippled by the fact that you use a screen protector, and now you'd like to
have a modification made to PocketSCUMM so that you can use it even
though part of your screen is unusable due to the screen protector.

Moving this to feature requests.

comment:13 by SF/arisme, 14 years ago

Well, it can probably be solved by using a screen protector
that does not interfere with the stylus resolution :)
Closing that.

comment:14 by SF/arisme, 14 years ago

Resolution: invalid
Status: newclosed

comment:15 by digitall, 13 months ago

Component: Port: WinCE
Game: Beneath a Steel Sky
Note: See TracTickets for help on using tickets.