Opened 16 years ago

Closed 16 years ago

Last modified 2 years ago

#7375 closed enhancement (duplicate)

Config file: look in current directory first

Reported by: salty-horse Owned by: Kirben
Priority: normal Component: --Other--
Keywords: Cc:
Game:

Description

On any platform, if a config file is found in the current dir, it should be the default. Only if that one is not found, go look in the platform specific location ($HOME, %WINDIR% etc)

It seems to me as the logical approach. Possible use: When I wanted to convert my classic dott/sam cd to a modern scummvm one, I wanted to create a read-only config file that already has the targets configured. The only way to tell scummvm to use the config file on the cd was via a command line parameter.

source: common/config-manager.cpp ConfigManager::ConfigManager()

Ticket imported from: #977802. Ticket imported from: feature-requests/191.

Change History (3)

comment:1 by Kirben, 16 years ago

Closed as duplicate of #743288

comment:2 by Kirben, 16 years ago

Owner: set to Kirben
Resolution: duplicate
Status: newclosed

comment:3 by digitall, 2 years ago

Component: --Other--
Note: See TracTickets for help on using tickets.