Opened 16 years ago

Closed 14 years ago

Last modified 10 months ago

#7353 closed enhancement (wontfix)

Add support for multiple monitors

Reported by: SF/sd-snatcher Owned by: SF/khalek
Priority: normal Component: Port: Win32
Keywords: Cc:
Game:

Description

Hi all,

- ScummVM: v0.6.0
- Platform: win32

- instructions on reproducing:

Start the game on the second monitor. It will run just
fine as a window. But, when you press ALT+ENTER to get
full screen, it happily goes to the 1st monitor.

- Details:

My notebook supports the TV-out only as the second
head. I can enable a "mirror option", but since it's
done by the driver by copying every frame to the second
head, the performance turns to be horrible.

I heard that many of the new notebooks behave this way
regarding the TV-output, so this problem will become
kind of "popular".

Thanks in advance,
FRS

PS: I don't know if this also happens on X-windows,
since I couldn't find a Linux-distro that works fine on
my machine yet.

Ticket imported from: #920665. Ticket imported from: feature-requests/169.

Change History (6)

comment:1 by fingolfin, 16 years ago

This is not a bug, it's a feature request. And strictly spoken, not a
ScummVM feature you are requesting either, but rather a SDL feature...

comment:2 by fingolfin, 16 years ago

Summary: Full screen doesn't work on the second head on win32Add support for multiple monitors

comment:3 by sev-, 15 years ago

I agree here. Modern setups let you define which
resolutions/applications should be rendered on which
monitor, and ScummVM has nothing to do it. I think this
should be rejected.

comment:4 by SF/khalek, 14 years ago

Owner: set to SF/khalek
Resolution: wontfix
Status: newclosed

comment:5 by SF/khalek, 14 years ago

As discussed this is outside the scope of ScummVM, closing.

comment:6 by digitall, 10 months ago

Component: Port: Win32
Note: See TracTickets for help on using tickets.