Opened 16 years ago

Closed 16 years ago

Last modified 11 months ago

#7341 closed enhancement (wontfix)

Disable saving/loading in certain scenes

Reported by: SF/einheitlix Owned by: Kirben
Priority: normal Component: --Other--
Keywords: Cc:
Game:

Description

I think it would be cool if it wasn't possible in ScummVM to save
games in scenes where the original interpreteres didn't allow it either,
i.e. at the end of Maniac Mansion when the meteor has taken over
the control, and at the end in Indiana Jones and the last crusade
during the three trials.

It was funny when you tried to save in Maniac Mansion and it said
"The meteor has taken the control over your computer!" (or
something like that), which is not implemented in ScummVM :(

Also, I think ScummVM should be as near to the original interpreters
as possible, shouldn't it? :-)

The idea comes from this thread:
https://sourceforge.net/forum/forum.php?
thread_id=984482&forum_id=115756

Ticket imported from: #857224. Ticket imported from: feature-requests/157.

Change History (5)

comment:1 by fingolfin, 16 years ago

Actually being able to save anywhere is a feature, not a bug.

And no, we don't strive to be as near to the original interpreters in
every imaginable way. We already derivate with our GUI, and with
fixing many bugs the original games suffered from.

Plus, even if we added this, it would only mean that you can't save
- you would *not* get those messages in Maniac Mansion, for
example.

comment:2 by SF/einheitlix, 16 years ago

Of course it's not a bug. If I thought it was a bug, I would have posted this in
the bug tracker, not as a feature request :-)

Of course, it'd only be fun not to be able to save if messages like "The
meteor has taken over control!" appeared. But why wouldn't this be
possible?

Even if you don't try to be as near to the original interpreters as possible -
still, I think it's part of the game not to be able to save, which is disabled in
ScummVM :-( Just as the feature request 834896 which I also posted btw,
and noone ever bothered to answer to that one (and that one is even more
important to me than this one, because one is missing whole scenes, like in
Zak McKracken, when you're put in jail etc., but that's another topic).

comment:3 by Kirben, 16 years ago

Owner: set to Kirben
Resolution: wontfix
Status: newclosed

comment:4 by Kirben, 16 years ago

Those messages would have been part of the original games
load/save system which we don't use and don't plan to use
anytime in the future.
As fingolfin already mentioned, this feature is a major
advantage of ScummVM. So rejecting.

comment:5 by digitall, 11 months ago

Component: --Other--
Note: See TracTickets for help on using tickets.