Opened 17 years ago

Closed 17 years ago

Last modified 2 years ago

#7336 closed enhancement (fixed)

Search more subdirs: Rooms 1, Rooms 2, Rooms 3

Reported by: SF/lechimp Owned by: Kirben
Priority: low Component: --Other--
Keywords: Cc:
Game:

Description

ScummVM 0.5.5cvs, Nov 11 CVS build MacOS 10.2.8, gcc 3.3 Indy3 and Loom Mac floppy versions, both english

The problem is that in the Mac distributions the LFL files are not placed in the same directory as the main application, but in three subdirectories ("Rooms 1", "Rooms 2" and "Rooms 3"). This is because the games were distributed on three floppies.

Thus the directory layout for Indy 3 is :

Indy™ Rooms 1 Rooms 2 Rooms 3

and for Loom : Loom™ Rooms 1 Rooms 2 Rooms 3

(All folder names are case-exact!)

ScummVM only looks for a "rooms" or a "ROOMS" folder it seems. Therefore, selecting the main application folder causes the "SCUMMvm could not find a game in the specified directory". It is possible to run part of Loom Mac by selecting the 'Rooms 1' folder, becuase it contains the '00.LFL' file. But later I run into a message saying '59.LFL not found'. Indy3 doesn't even go further than the LucasFilm intro screen. Obviously if I flatten the entire directory structure and put them all in a "ROOMS" folder, it works.

Ticket imported from: #841848. Ticket imported from: feature-requests/152.

Change History (8)

comment:1 by SF/lechimp, 17 years ago

Priority: normallow

comment:2 by fingolfin, 17 years ago

Component: Engine: SCUMM
Game: Loom
Summary: LOOM/INDY3 (MAC) : load pathSearch more subdirs: Rooms 1, Rooms 2, Rooms 3

comment:3 by fingolfin, 17 years ago

So this is not a bug, rather you seem to (indirectly) request a new feature: namely automatic searching of subfolders "Rooms 1" etc. ?

comment:4 by SF/lechimp, 17 years ago

Well yeah, I guess that is so. I think the reason for submitting this as a bug report was that I couldn't get the original distributions to work with ScummVM. So according to my twisted sense of logic it seemed more appropriate to classify it as a bug report than a feature request. If I were more experienced with CVS, I'd probably apply for write access and subsequently add those three lines myself, but I'd like to wait until I am sure how it works.

comment:5 by SF/logicdeluxe, 17 years ago

Would it be possible just to add several paths separated by semicolons like it is usually done in the path environment variable? For example: path=c:\games\indy3\rooms1;\c:\games\indy3\rooms2

This would fix this problem and also covers the feature request 650677.

comment:6 by SF/lechimp, 17 years ago

Hmm.... I don't know. Perhaps the major problem with the directories is that the main folder only contains the Indy/Loom application and the folders. Since the game detector does not detect the game type from the applicaton file, one would still have to specify the location of the 00.LFL file ("Rooms 1") as the game directory. So the additional paths would be ../Rooms 2/ ../Rooms 3/

*sigh*

Or maybe it would be better to have a dynamic path. Example : ScummVM searches in the standard subfolders and doesn't find the needed file. An error message informs the user and a popup dialog lets the user find the file. After the file is found, the specified directory is added to the path and maybe written to the config file for the next use.

comment:7 by Kirben, 17 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:8 by digitall, 2 years ago

Component: --Other--
Note: See TracTickets for help on using tickets.