Opened 16 years ago

Closed 16 years ago

Last modified 13 months ago

#7293 closed enhancement

SIMON: Remap instruments to GM

Reported by: (none) Owned by: SF/jamieson630
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

Using scummVM v.0.5.0pre-cvs under WinXP with -
ewindows I only get the MT32 soundtrack of Simon 1,
which therefore sounds terrible on my GM soundcard. I
know I could just play the game on my old computer
with my trusty MT32, but it would be nice if you could
remap the instruments to GM the way it's been done for
MI2 or BASS.

Ticket imported from: #770161. Ticket imported from: feature-requests/109.

Change History (10)

comment:1 by Kirben, 16 years ago

Owner: set to SF/khalek
Resolution: invalid
Status: newclosed

comment:2 by Kirben, 16 years ago

There was only one set of music tracks in Simon the Sorcerer
1, which were standard midi files, although dos versions used
a custom header. And the music sounds fine when I compare
ScummVM to the original games.

comment:3 by Kirben, 16 years ago

Owner: changed from SF/khalek to Kirben

comment:4 by (none), 16 years ago

There was indeed only one set of music tracks, but those
definitely were for the MT32. Just try to install the game
under DOS: you'll be offered MT32 (not GM!) for music.
I know that, when they released the windows talkie version,
the nice folks at AdventureSoft lazily decided to just send the
MT32 music to whatever sound card the player had, probably
thinking that, since they didn't use any MT32 custom
instrument and since the game music mostly used strings and
flutes, which have the same instrument numbers under MT
and GM, nobody would notice. So, if you're playing the game
under windows with a GM soundcard, you may never have
heard the score as it was supposed to sound.
There's one easy way to check: those instruments which did
not have the same number with MT32 and GM. For instance,
start the game and go to the druid's home. The first
instrument you hear should be a kind of xylophone (MT32
instrument 100: Synth Mallet); what I get, using either the
original interpreter under Windows or ScummVM (with my GM
soundcard) is GM instrument 100: Atmosphere. And that
makes the track sound terrible.
Hence my asking for instruments being remapped :)

comment:5 by (none), 16 years ago

Status: closednew

comment:6 by Kirben, 16 years ago

Owner: changed from Kirben to SF/jamieson630

comment:7 by Kirben, 16 years ago

OK I compared Simon 1 music to the mod music included in
Amiga CD32 and confirmed they are MT32 tracks which need
remapping. I really can't believe Adventure Software did this,
all this time I have been listening to the incorrect music!

jamieson620, please add MT32 to GM mapping to Simon1 (All
versions, including demo) by default when you have time,
with MT32 native option to disable it (--native-mt32).

comment:8 by SF/jamieson630, 16 years ago

Resolution: invalid
Status: newclosed

comment:9 by SF/jamieson630, 16 years ago

Wow, it never dawned on me either, that the program
changes in the MIDI tracks might be for MT32. Okay, Simon 1
now does an MT32-to-GM transformation of instruments,
*except* when the --native-mt32 option has been specified.
Thanks for pointing this out, manwe21. Closing.

comment:10 by digitall, 13 months ago

Component: Engine: AGOS
Game: Simon the Sorcerer 1
Note: See TracTickets for help on using tickets.