Opened 16 years ago

Closed 15 years ago

Last modified 12 months ago

#7278 closed enhancement (wontfix)

LOOMCD: Subtitles impossible to turn off

Reported by: SF/thunderpeel2001 Owned by: Kirben
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

I've sent this bug in before, but it has disapeared from
the database and not been fixed in the latest version
(0.41).

When LOOM CD starts a message from ScummVM is
generated that says: "Press F9 to toggle subtitles".

The user then clicks their mouse to get past this
message and the control of the game begins.

Now pressing F9 brings ups the following messages
alternately:

"Text WILL appear on the screen"

and

"Text WILL NOT appear on the screen"

Which ever one is chosen, text always appears on the
screen to match the dialogue.

This was seen when using an MP3 to recreate the
sound, and has not been tested with an actual CD,
although I don't know if it would make any difference?

I have also tried adding the "nosubtitles=true" line to
the LOOM CD section of the scummvm.ini file, but that
failed to make any difference.

Thanks.

Ticket imported from: #752328. Ticket imported from: feature-requests/94.

Attachments (1)

subtitles.gif (115.7 KB ) - added by SF/thunderpeel2001 16 years ago.
The ScummVM generated message at the beginning of the game (LOOM CD)

Download all attachments as: .zip

Change History (17)

by SF/thunderpeel2001, 16 years ago

Attachment: subtitles.gif added

The ScummVM generated message at the beginning of the game (LOOM CD)

comment:1 by fingolfin, 16 years ago

Owner: set to fingolfin
Resolution: wontfix
Status: newclosed

comment:2 by fingolfin, 16 years ago

This is not a bug, and it has not disappeared, it has been moved to
the feature request section: <http://sourceforge.net/tracker/
?func=detail&atid=418823&aid=736863&group_id=37116>

comment:3 by SF/thunderpeel2001, 16 years ago

Umm? It IS a bug! The user is told to press F9 to turn the
text on and off. A message pops up TELLING the user that
the text has been turned off... but it doesn't actually work!

It wouldn't be a bug if these +ScummVM+ messages weren't
there, but they are! It's like saying "Press F5 to save your
game" and nothing happening when they press F5: It's not
a "feature request", it's a bug!

To reiterate: The messages are generated by ScummVM, not
LOOM. To fix the bug the messages could be removed (a
temporary fix) or they could fix the problem.

Thanks.

comment:4 by SF/thunderpeel2001, 16 years ago

Summary: Subtitles impossible to turn offLOOMCD: Subtitles impossible to turn off

comment:5 by SF/thunderpeel2001, 16 years ago

Priority: normallow

comment:6 by SF/thunderpeel2001, 16 years ago

Priority: lowhigh

comment:7 by SF/thunderpeel2001, 16 years ago

Status: closednew

comment:8 by SF/thunderpeel2001, 16 years ago

Owner: fingolfin removed

comment:9 by fingolfin, 16 years ago

Please stop messing with our tracking system. It is up to us to
decide what we consider a bug, and what not. Same goes for item
priorities, *we* decide in which order we are going to fix things.

comment:10 by fingolfin, 16 years ago

Component: Engine: SCUMM
Game: Loom
Keywords: script removed
Priority: highlow

comment:11 by SF/kaminari, 16 years ago

Thunderpeel, this is how the original interpreter behaves. Try
it under DOS. Definitely a feature request -- not a bug.

comment:12 by eriktorbjorn, 15 years ago

The F9 key works in the CVS version of ScummVM. I don't
remember if it does in 0.6.0. Turning of subtitles at
startup (either though the config file or through the
command-line) doesn't seem to work yet though, so I'm
leaving this open for now.

comment:13 by Kirben, 15 years ago

Owner: set to Kirben
Status: newclosed

comment:14 by Kirben, 15 years ago

The reason is a few sections (ie introduction and ending
sequence) of Loom (CD) auto enable subtitles in scripts and
use CD audio for music only. But these script changes can't
safely ignored.
We can only detect whether subtitles should be shown in
Loom (CD) by checking whether CD audio is currently
playing. Checking the exact music track been played would
not help either in these scenes either.

So could end up with with subtitles in introdutction and
ending sequences been disabled, if we always just used the
subtitle setting from config file.

Closing, since I see no way to improve this situation.
Enabling/disabling subtitles once Loom (CD) is started, is the
best you will get.

comment:15 by fingolfin, 13 years ago

It would be a good idea to document this known issue appropriately in the README, then.

comment:16 by digitall, 12 months ago

Component: Engine: SCUMM
Game: Loom
Note: See TracTickets for help on using tickets.