Opened 17 years ago

Closed 17 years ago

Last modified 12 months ago

#725 closed defect (fixed)

GUI: Save/Load box missing some letters in Spanish

Reported by: SF/jellby Owned by: fingolfin
Priority: normal Component: GUI
Keywords: Cc:
Game:

Description

ScummVM 0.3.2cvs
Built on Mar 23 2003 13:57:25
System: RedHat 7.3
(Found in scummvm-0.3.0b (rpm) too)

When I'm playing a Scumm game in Spanish (it probably happens in other languages) and I press F5, some buttons in the box are missing the first (capital) letter (and sometimes the last letter too). In the file I've attached there are 3 examples:

Day of the Tentacle: "uardar" shoud be "Guardar"
Sam and Max (CD): "uardar" should be "Guardar", "ecupera" should be "Recuperar" and "ermina" should be "Terminar"
Monkey Island 2: "bortar" should be "Abortar".

I first thought the problem was the capital letters not being defined or something like that, but I've just found out the last letter is missing in a couple of cases, so now I think the problem is the width of the text being too much for the button.

Ticket imported from: #709653. Ticket imported from: bugs/725.

Attachments (1)

BugF5.png (5.2 KB ) - added by SF/jellby 17 years ago.
Save/load box buttons with some letters missing.

Download all attachments as: .zip

Change History (7)

by SF/jellby, 17 years ago

Attachment: BugF5.png added

Save/load box buttons with some letters missing.

comment:1 by SF/jellby, 17 years ago

Erm.... I don't see the file here, I'll try attaching it again. In case it doesn't work, you can see it (for some time) here: http://www.terra.es/personal5/jignafez/images/BugF5.png

comment:2 by fingolfin, 17 years ago

Owner: set to fingolfin

comment:3 by fingolfin, 17 years ago

File attachment is not here (make sure to check the checkbox when addinf files), but the URL works fine.

The problem is indeed the width of the text. The only viable solution I see is for us to increase the buttone width a little more <sigh>. Up to two letters are missing: "R+r" and "T+r", at least in your examples.

Since I don't have the spansih versions, you can maybe save me a little work: Edit gui/widget.h, and increase the value of kButtonWidth (currently 56). Try 60 and 64. Then check if the buttons are now wide enough, if not, increase again, etc. Of course the rest of the layout needs to be adjusted, too, but I can do that later, I just need to know how wide the buttons have to be (ideally the minimal size should be used).

Thanks!

comment:4 by SF/jellby, 17 years ago

I did check the attachment box the first time, there must have been a problem somewhere...

Anyway, I did modify the width and found that, for "Recuperar" to be shown correctly, the minimum width is 70. It may still be too small for other languages/games, however.

comment:5 by fingolfin, 17 years ago

Resolution: fixed
Status: newclosed

comment:6 by digitall, 12 months ago

Component: GUI
Note: See TracTickets for help on using tickets.