Opened 17 years ago

Closed 17 years ago

#722 closed defect (fixed)

DIG: Strange graphics corruption with inventory screen

Reported by: SF/pagefault Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

There is some strange graphics corruption when the inventory screen is on top of some animation in the background. To see it simply open the inventory screen from the save game included.

I am using the Win32 version. ScummVM 0.3.2cvs Built on Mar 20 2003 12:16:11

Ticket imported from: #706721. Ticket imported from: bugs/722.

Attachments (1)

dig.s01 (208.7 KB ) - added by SF/pagefault 17 years ago.

Download all attachments as: .zip

Change History (7)

by SF/pagefault, 17 years ago

Attachment: dig.s01 added

comment:1 by eriktorbjorn, 17 years ago

This is the same as the third issue of bug #635369, "DIG: Bomp regressions". Though since that report really doesn't offer any insights, and brings up other - now fixed - issues as well, perhaps we should close that one and keep this one instead?

comment:2 by fingolfin, 17 years ago

Erik, feel free to do so.

comment:3 by fingolfin, 17 years ago

Still happens in latest CVS.

AFAICT; the bomp drawing code seems correct. The real problem here is not animation, either, it's color cycling: the "odd effect" is caused by inventory colors being cycled.

A stab in the blind: maybe this is due to a bug in setupShadowPalette?

comment:4 by fingolfin, 17 years ago

According to aquadran, the original stops color cycling while the inventory is up, that might fix this problem.

comment:5 by fingolfin, 17 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:6 by fingolfin, 17 years ago

I fixed this by cycling the shadow palettes, too.

Note: See TracTickets for help on using tickets.