Opened 22 months ago

Closed 7 months ago

#7181 closed defect (wontfix)

SDL1: mouse error when using SDL1, 3x and full screen, was: SQ5: Space Bar walking bug (can't enter brig)

Reported by: SF/captainjei Owned by: csnover
Priority: low Component: --Unset--
Keywords: Cc:
Game:

Description

ScummVM version: 1.9.0git4226-g5b7ad5c (Aug 11 2016 21:40:14)
Language: English
Game: Space Quest V floppy
Platform: Win32

While in the Space Bar I'm unable to get Roger to walk off the screen to the right to enter the brig area. He just walks to the edge and stands there. I've started over from the beginning to determine that this happens on every playthrough (at least for me). It prevents further progress in the game.

Ticket imported from: bugs/7181.

Attachments (1)

sq5.096 (41.4 KB) - added by SF/captainjei 22 months ago.

Download all attachments as: .zip

Change History (11)

Changed 22 months ago by SF/captainjei

Attachment: sq5.096 added

comment:1 Changed 22 months ago by m-kiewitz

Which version is this? 1.04?

comment:2 Changed 22 months ago by m-kiewitz

Walking to the right works for me. Roger strangely walks a bit to the left and then to the right, but he enters the next screen.

comment:3 Changed 22 months ago by SF/captainjei

Okay, I tried again. I can get Roger to walk into the brig as long as the game is being played in a window, but not in full-screen mode (with or without aspect ratio correction).

I don't know how to tell which version I have. It's either from my Space Quest Collection CD or the GOG version (most likely the former).

comment:4 Changed 22 months ago by m-kiewitz

Maybe your full screen mode doesn't let the mouse click at the right edge?!

Do you use OpenGL? Or SDL?

You can check the file called VERSION. But I assume it's 1.04 as well.

comment:5 Changed 22 months ago by m-kiewitz

I just tried full screen mode as well and it works too.

comment:6 Changed 22 months ago by SF/captainjei

I don't know what SDL means, but I had the graphics mode set to 3x.

I tried loading the game under different graphics modes, and the walking problem only seems to occur when set to 3x or HQ3x, full screen. What seems to be happening is that in these modes ScummVM lets you move the pointer farther to the right than one can in a window or in other graphics modes to the point where it's completely off the screen., and I'm speculating that it's interpreting a click in that region as more to the left than it is.

If I move the pointer to where it's only slightly off the right side of the screen walking works normally.

(It's version 1.04).

comment:7 Changed 22 months ago by m-kiewitz

Ah, now I'm able to reproduce it.
3x + full screen seems to be broken for the mouse. But this seems not to be a SCI engine, but an overall system issue.

comment:8 Changed 22 months ago by m-kiewitz

Component: Engine: SCI--Unset--
Game: Space Quest 5
Summary: SQ5: Space Bar walking bug (can't enter brig)SDL1: mouse error when using SDL1, 3x and full screen, was: SQ5: Space Bar walking bug (can't enter brig)

comment:9 Changed 22 months ago by SF/captainjei

Indeed. Thanks for your help and your patience!

comment:10 Changed 7 months ago by csnover

Owner: set to csnover
Resolution: wontfix
Status: newclosed

There is still some cross-platform issue with SDL1 here, in 3x mode there’s some dead space at the right/bottom in fullscreen. This is more obvious with the new graphics manager code since the system cursor gets rendered when the mouse falls outside the game area, so at least now there is a visual hint as to what is happening. Manually toggling on mouse capture in SDL1 with ctrl+m fixes the problem. SDL2 does not have this problem, so I am going to close this ticket since the final solution is to upgrade to SDL2 now.

Note: See TracTickets for help on using tickets.