Opened 3 years ago

Closed 17 months ago

#7143 closed defect (fixed)

MOHAWK: Myst Masterpiece Stoneship Red page door graphics glitch

Reported by: SF/pegasusepsilon Owned by: bgK
Priority: normal Component: Engine: Mohawk
Keywords: Cc:
Game: Myst

Description

System: Android (lollipop)
Game: Myst Masterpiece Edition
Age: Stoneship

Red page room door, with the lights on, plays the opening animation (and displays the open door) in the wrong place, with varying degrees of severity.

Screenshots attached:
mystbug1.png (door closed)
mystbug2.png (door open, badly misplaced animation)
mystbug3.png (door open, not so badly misplaced animation, but still off)

Ticket imported from: bugs/7143.

Attachments (3)

mystbug1.png (197.6 KB ) - added by SF/pegasusepsilon 3 years ago.
mystbug2.png (215.8 KB ) - added by SF/pegasusepsilon 3 years ago.
mystbug3.png (189.9 KB ) - added by SF/pegasusepsilon 3 years ago.

Download all attachments as: .zip

Change History (11)

by SF/pegasusepsilon, 3 years ago

Attachment: mystbug3.png added

comment:1 by SF/pegasusepsilon, 3 years ago

Upon looking at it further, I think mystbug3.png is actually showing the open door as it would be if the lights were off, but the hallway itself is lit. So that's even weirder.

comment:2 by bgK, 3 years ago

Component: Engine: SCUMMEngine: Mohawk
Game: Myst
Summary: Myst Masterpiece Stoneship Red page door (lights on) displays open animation in wrong place on screenMOHAWK: Myst Masterpiece Stoneship Red page door (lights on) displays open animation in wrong place on screen

comment:3 by bgK, 3 years ago

mystbug3.png is the correct (original) behaviour.

I've been unable to reproduce mystbug2.png using the Android emulator.

comment:4 by SF/pegasusepsilon, 3 years ago

I wouldn't say it's correct, but I cede that it appears to be accurate emulation. I suspect it's a bug in Myst Masterpiece Edition, and not ScummVM, and propose that this issue be closed-invalid.

comment:5 by dafioram, 2 years ago

I am able to reproduce this bug (mystbug2.png) on my android tablet 4.1.1 with scummvm 1.9.0.1. ScummVM 1.9.0.1 is an old version of myst so I don't know if this bug is still present on android with the latest scummvm version. I have tested this on windows with the latest scummvm version (oct 26) and it is not present.

This requires someone with a newer android scummvm version to test.

comment:6 by dafioram, 23 months ago

Owner: set to dafioram
Resolution: outdated
Status: newclosed

ScummVM: Android-arm ed638bac (11/27/2017)
Device: Tf201
OS: Android 4.1.1

This is no longer an issue on the latest scummvm (buildbot).

comment:7 by dafioram, 17 months ago

Resolution: outdated
Status: closednew

This is in the current version.

Turn the lights on and press the special button. Then open the right brothers door. Not specific to android.

comment:8 by dafioram, 17 months ago

Owner: dafioram removed

comment:9 by dafioram, 17 months ago

Summary: MOHAWK: Myst Masterpiece Stoneship Red page door (lights on) displays open animation in wrong place on screenMOHAWK: Myst Masterpiece Stoneship Red page door graphics glitch

Doesn't happen in the original.

comment:10 by bgK, 17 months ago

Owner: set to bgK
Resolution: fixed
Status: newclosed

Thanks for your report, this was fixed in commit 8d654285cbf0bf6423676244c89833557f811e38.

Note: See TracTickets for help on using tickets.