Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#7110 closed defect (fixed)

Using coin into machine makes ScummVM 1.8.0 crash (Spanish version)

Reported by: SF/jomalin1 Owned by: TMM
Priority: normal Component: Engine: Drascula
Keywords: Cc:
Game: Drascula

Description

Using Drascula (Spanish version), loading the savegame i provide, using the coin into the machine (this is the second time i used the coin, after the first time it works well and you get tobacco), crash ScummVM in the third sentence the protagonist say. I am using ScummVM 1.8.0 on Win7 64 bits.

I downloaded the game from the official website (now the game is free):
http://www.alcachofashop.com/product_info.php?products_id=32&language=es

Ticket imported from: bugs/7110.

Attachments (3)

drascula-es.004 (14.9 KB ) - added by SF/jomalin1 4 years ago.
drascula.001 (15.0 KB ) - added by SF/jomalin1 4 years ago.
back_trace.txt (8.5 KB ) - added by Kirben 4 years ago.

Download all attachments as: .zip

Change History (12)

by SF/jomalin1, 4 years ago

Attachment: drascula-es.004 added

comment:1 by SF/jomalin1, 4 years ago

I tried spanish Drascula on Dosbox 0.74 and it does not crash, so looks like it is an ScummVM error

by SF/jomalin1, 4 years ago

Attachment: drascula.001 added

comment:2 by SF/jomalin1, 4 years ago

The bug does not happen in the english version of the game. Savegame attached

comment:3 by criezy, 4 years ago

Strange. I can't reproduce with version 1.8.0 on OS X. Could this be a Windows specific issue?
I first tried with the game data available on our web site since I already had them (http://www.scummvm.org/games/#drascula) and then to make sure I downloaded the ones from your link (and after checking they are binary identical to the ones we have).
With your save game it doesn't crash for me when I use the coin into the machine.

comment:4 by criezy, 4 years ago

Some further tests: It does indeed crash with our Windows 1.8.0 release (I tried on Windows 10 64 bits). However it doesn't crash with the version I compiled myself or with the version from our buildbot (http://buildbot.scummvm.org/builds.html - although the stable version there is slightly more recent than 1.8.0). So it looks like this might be an issue with the way we compile the release build.

comment:5 by SF/jomalin1, 4 years ago

But did you try my spanish savegame or my english savegame? It only crashes with the spanish savegame (drascula-es.004)

comment:6 by criezy, 4 years ago

Yes, I used the Spanish version and your Spanish save game for all my tests.
But anyway, as I wrote in my following update, I did reproduce the crash on Windows with our official release (and only with that one).

by Kirben, 4 years ago

Attachment: back_trace.txt added

comment:7 by Kirben, 4 years ago

The problem only occurs when a release build is enabled on Windows, specifically only when optimizations are enabled in GCC 4.6.2 under MinGW. The problem is specific to GCC 4.6.2. under MinGW, and doesn't occur with GCC 4.9.3. under MinGW.

I attached a back trace if it is any use, some variables are optimized out though.

comment:8 by criezy, 3 years ago

Owner: set to TMM
Resolution: fixed
Status: newclosed

After testing again with the 1.8.0, 1.8.1 and 1.9.0 releases for Windows I can confirm that the crash happens with version 1.8.0 but not with versions 1.8.1 and 1.9.0.

comment:9 by wjp, 3 years ago

Just to be on the safe side, I've added some asserts to the copyRect function Kirben's backtrace points at.

Note: See TracTickets for help on using tickets.